The end of the servers is near

Hi just to mention that since a few minutes now, much people experience trouble to connect to the game on PS4

I’ve had some odd errors on Xbox and some connection issues as well

I’d guess that the servers are hosted in a similar location to the PC ones, and they’ve been having issues for the past hour or so.

thanks from your support. Seriously this needs to be fixed.

I believe it’s being worked on. (assuming it is the same issue)

I keep getting connection errors on Xbox as well. Happened at least 6 times before I was on the map screen. They pop up stating: “Error. There was a problem contacting the server. Please wait a few minutes and restart your game.”, which I did. Did not resolve the issue.

I can’t even get into the game. It’s just one error after another.

2 Likes

I just got on, leveled a troop to 15 for the task, spent some keys and everything seemed fine, now I’m stuck in the PvP screen just loading

the servers are having some problems. it is 3am where they are but hthe problem has been identified and is being worked on… (update from the pc side)

same, yesterday had a weird crash i havent had yet. before ive had that sometimes after the initial gems of war screen (so before the loading screen) the screen turned black and stayed that way.

Right now i can barely get in but keep getting “problem when trying to contact the server” error messages. Ive had these from time to time before but right now i cant get around it to play. ;[

I can no longer enjoy life without gems of war i must throw myself off a cliff now brb

This is the end :disappointed:

we have no choice but to mass suicide :fearful:

1 Like

you are back , must of been a small cliff or cushion/water under it

This is because de end of week. Everyone wants reward.

i am always back. :persevere:

Connection issues on Android with a empty box with ‘SUPPORT’ button on it.

Tried with my iPad, went to collect my daily award in the mail box and got the same error and now I can’t reload the game/connect.

I could even play a duel but not finish it
at least it completed a task

For the horde! Let’s roll, bro–

3 Likes

Ah, so there IS a server problem then - I was worried that it might just be me.

I’ve been attempting to play on the PC, and can’t log in either. Fingers crossed that they’re able to get things running again soon…

Havent been able to login for awhile now. Will these issues ever be fixed? Apple iphone