3.2 Known Issues (PC/Mobile/Console)


Reinstall GoW fixed my dungeon issues (same as you) as well as others(like no graphics for gem stones). Make sure you have your password to link account 1st tho


Hi. Am using samsung J5 to play the game. Since the update I can’t see all graphics. There are no images to show what I need to make things in the soulforge. I can see numbers needed but that’s all. Frustrated


Emperor Khorvash just stunned my first two troops AND my last troop. these troop bugs are getting out of control.

playing on Steam.


Why can we not see someone’s home kingdom now when we click on their name? Is this something that they’re still working on? Playing on console.


The game when I load the game keep download 2,19Mb pc/mobile is normal?


From the layout of the card, there’s no space to put the Kingdom Crest on.
On the face of the card - it has to be on the face since it’s borderless - you have all the stats.

Plus the Black Bands of Mourning because their use of fonts is fundamentally broken and they cannot contour - nor scale - them, so they had to put black smoky bands behind white stats covering the art.

At least the basic rules of design are mourned upon.


I still can not login, still back screen for me even i reinstall from android Lg V10, Does it mean i should give up or still need to wait


Most likely your last troop might have got stunned by his 3rd trait.


Did arena run on my lady’s account but got no trophies towards daily tasks. My fiancee is not in a guild but said in rewards tab trophies would be awarded, then no trophies in reward tab.


(Xbox) on world map, my gold income top right screen show: % 1 / h


Dungeon doens’t work as before.
When I tap Games or Drifting Sands the first time: no options are loaded, ie empty screen.
Second time I can enter the Dungeon, but text is not loaded properly (shows Ttile_Opponent and Opponent_name templates for 2nd and 3rd boss) and Fight buttons don’t respond to tap/click.

Tested on iOS 10.3.3 (iPhone 6S)
Have tried restarting and rebooting phone, same result.


there is space to put Kingdom name in a text, on the bottom of the card, below the spell description for example (the same way as they put the troop type)

not saying its an ideal solution but it would still be a great improvement compared to not having any kingdom indicator

3.2 Feedback and Suggestions

I can´t play PVP anymore! (X BOX ONE)
I played this morning till 9am and then the game said new event starting soon come back in a few minutes, 5 hours later i still get this error message, i cant play PVP and cant spent money into guild tasks and i dont get stuff from guild tasks. I got my daily login stuff and i can play the dungeon and kingdom challenges and i see what the new event is!?!?! Another strange thing is everytime i start the game it makes always the 2 same mini updates (1 and 2 MB). All my friends can play the game without this problem. Never had such an issue before the Update. I re installed the game and make a hard reset on my xbox but stil havel the same error.

Since today all worked fine again :smiley:


I can’t play PvP in Xbox one since a few hours. A message appears that say new event starting soon come back in a few minutes. I’ll have uninstalled the game and hard reset the console but nothing works this error is still there.


Like the two posts above me, since the reset, I get errors when I try to donate to the guild or PVP, making both impossible, and I am not receiving any guild rewards for tasks that have been completed. I’m on Xbox as well.

So in addition to the horrible UI changes, I pretty much can’t play at all.


Just in case: this issue with Dungeon not being playable is only happening (to me) on mobile. I can get to the Dungeon fine on PC (as of 10/23).

Not sure if the ticket submitted specified a platform.


Ditto but on the ps4


i found i had to uninstall, clear cache, reboot, then reinstall. that seems to have fixed my android problems. and it had to be done in that order… any other didn’t seem to work… so just doing cache, just doing reboot, just doing uninstall.


Thanks, I’ll give it a try!


In the Android mobile version, the Dungeon section is not working. You click on the green button to play and nothing happens.