Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

Urskaya falsely claims that power 17 is the max

Platform, device version and operating system:
Android 8.1.0 on OnePlus 5T

Screenshot or image:
Embedding screenshots in the next comment below.

What you were expecting to happen, and what actually happened:
Thanks to lucky rolls I finally was able to get Urskaya to power 17 today. It then said that it is not yet achievable to trait more troops:

But, it is possible. Behold an untraited troop:

So I traited it and got to power 18.

How often does this happen? When did it begin happening?
Dunno. Happened today. I assume this bug was introduced with the new legendary release.

Steps to make it happen again
Get Urskaya to power 17.

Edit
Looks like a game restart fixes this. It is still a bug in my opinion, so I won’t mark this post. The devs can decide.

1 Like

What does the kingdom information say now in regards to 18-19 stars? Because level 19 is the current max.

If you took the SS right after reset and didn’t restart the game then it’s possible the kingdoms information right refresh. But you were able to find the troops because the servers chests updated. (I have no clue when you took the SS, it’s just my best guess.)

1 Like

Oh good point. 18 isn’t the max but the game says it is.

Restarted my game, and I no longer get that unavailable message.

I am going to guess if I had restarted earlier, the game wouldnt say 17 is the max.

Meh, will leave this bug report open for the devs anyway since I can’t confirm that.

1 Like


I don’t have Enraged Kurandara and still haven’t got Ursuvius.
Mine is normal.

1 Like

If the restart fixed your issue. Then it’s not a bug. Just the server didn’t update the info. Because you seemingly hadn’t restarted since weekly reset so your information was out of date.

Here’s the current max information with the correct “not achievable yet” stuff.

1 Like

A server shouldn’t need me to restart my game to send correct info, hence why I view this as a bug. I think it is just one if those livable, doesn’t really matter bugs.

1 Like

Your Kingdoms aren’t linked to the server Snooj. Weekly reset sends the server information to them so they can get the new info. Like 2 new troops being added to the Urskaya kingdom.
You’ve honestly never heard a dev ask players to always restart the game after weekly reset so that the current information can populate?

I am a dev. I am guessing powering up a kingdom uses a server connection so that it can verify. They could also code that kingdoms to update their info each Monday (this is inefficient, and there are better ways to do this).

With how this was designed, I would call it a bug.

Restarting the issue fixed it, sure, but that is a workaround to a bug.

1 Like

You aren’t a developer of Gems of War though. And yeah maybe I mispoke by saying the kingdoms aren’t connected to the server. But certainly they aren’t connected 24/7.
I don’t know what makes it check on kingdom stars. I don’t think it’s the server though. I think it checks the troops collection (and all other prerequisites) that’s why it knew you could upgrade yours before it “said it was possible”.

But clearly you want Salty to tell you it’s not a bug. So by all means. Have at you.

This is odd.

I am going to follow the definition of bug as I would use it professionally over you. There is no harm in leaving this bug report open, and this is a weird convo. I don’t care if Salty responds, or how she responds. I don’t expect this fixed anyway because there is a simple workaround.

If you feel better thinking I want someone specifically to tell me something, ok, go for it. :woman_shrugging:

Updated the comment.
I was in the middle of my reply and received a text. Didn’t realize where I had left off on the message and ended up repeating a thought. I can easily replace Salty with a developer of Infinity Plus 2 and my point would remain the same. All I’m saying is you want someone “official” to tell you it’s not a bug.
And I’m not official.

1 Like

It’s not just kingdoms, there’s a whole bunch of data like event information and store offers. Apparently it can’t be hot swapped into the game while it’s running. Going by global chat it’s causing confusion every weekly reset. I wonder why they can’t treat it like expiring pet battles, by force restarting the game.

3 Likes

If I’m playing around reset, wich I do pretty much daily, I just log out a min before reset, wait a bit and log back in.

It’s not just the kingdom info that needs this refresh, battles like dungeons keep showing completed if you didn’t restart for example.

If you keep playing, around reset on a Monday morning and back out the battle, the game will kick you to the update screen for the week but that will not update your kingdom info or dungeon battles completed (you can still enter the new dungeon battles anyway). To me this feels bugged, just kick me out of the game at reset then if that’s the point…

1 Like

I’m not saying any of you developer minds are wrong in thinking the system is wrong.
I just don’t believe the devs of GoW will consider it a bug.
I had the unfortunate education in regards Kingdom stars from 21-22 effecting Daily Offers. Everything about GoW telling me it was a bug. But Kafka just flatly telling me that it wasn’t a bug. My brain breaking. Other peers discovering a work around for the “not a bug” to get the daily offers that were triggered by the “not a bug” to cease and desist. (don’t know if that phrase actually works in this case I just like saying it😉.)
Months later it took another peer to paraphrase what Salty said on a stream to explain on here why the daily offers weren’t a bug.

Basically if the devs want something to work that way. Even if it’s nonsensical. Or could be done better. It’s not a bug. And this is just feedback. Which is fine.

For instance is having 2 different traits in the game that do exactly the same thing but are labeled 2 different ways a bug?
Nope. Just lazy ass design. 🤷
Screenshot_20210302-112046
Screenshot_20210302-111955
(Original credit to @Crow for being the first to point it out to me.)

2 Likes

Actually this may be a bug for you. Even though I don’t restart my game, my dungeons do not show as completed the next day.

Yeah, it’s been interesting seeing how everyone uses the word bug on these forums, not just this post. I agree the devs won’t consider it a bug. To be fair to everyone, I guess I use the word bug when really I mean “defect” which includes not accounting for edge cases or poor design.

I definitely view this as a bug. Er, defect. :rofl: I’d bet money the devs won’t, though I am curious if anyone has opened a bug report for this? The future of filtering by traits will be fun. I often filter for converters where you can pick a colour, and have to do two searches: “select” and “chose”, because they’re inconsistent. One day there may also be “pick”, “target”, “click”… :scream:

Edit: Just saw you made a bug report 10 minutes before I made this comment. Let’s see what happens. :popcorn:

I just did after posting about it. Because though I don’t think it’s a bug. Their lack of professionalism is “bugging” me. And at least by submitting it as a bug that gives them an out to change the trait.

I feel like that’s different than your case. Because you initially thought it was a bug. Then I tried to help clear up why you saw that you saw “in regards to not achievable yet”. And now you want the whole system to be revamped. Which all the power to you.
Maybe the situations aren’t apple and oranges.

But it’s entirely possible that the two traits were labeled differently due to oversight… so bug in the brain?

1 Like

Might be a Xbox thing idk, I’m not gonna bother reporting it.

Anyway not quiting the game before reset and just keep playing results in the following on X1

On the game tap “Dungeons” still show completed, even if completed before reset

Any sigil related event will show you have 0, but going into a battle will fix that.
Pretty sure there’s one more, just can’t think of it right now.

Daily tasks do update, same goes to campaign

1 Like