Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

Server calls make Tribute icon disappear (both console AND iOS)

@Alpheon @Nimhain
I just wanted to mention that in the past few days, I’ve noticed that if I check my in-game Mailbox or donate gold to my Guild, the flashing Tribute icon often disappears before I have a chance to claim it.

This appears to be a brand new bug. I have been missing out on the Tributes left, right, and center, especially on Xbox One, because whenever I transition from a PvP match to the Worldmap or to the Mailbox, I’m doing a server call that wipes out my hourly Tribute that should have been there.

I have also noticed this issue occurring a few times on my iPad Mini 3 game.

Here’s a Guild contribution Error I received on XB1 at 2:54pm EST today, right before one of my Tributes disappeared:

I didn’t get the Glory Keys for completing this task (Exploration), either. :worried:

1 Like

Sorry to hear this is happening to you. I’d recommend opening an actual support ticket here: https://gemsofwar.zendesk.com/hc/en-us/requests/new

On xbox tribute has never stacked properly. Keys and glory don’t register properly when offline and never have or will. Noticeable more when you have over half 5 star kingdoms.
And yes of late tribute does now totally disappear randomly - lower than 10% say. Its the biggest difference between pc and xbox that I can see. of course this does encourage players to spend money in the shop, so presumably by design. Console payers are always seen as cash cows.

@ogunther, thanks for the suggestion about filing a ticket. I admit, I’m sort of afraid to at this point. Support’s actual recommendation was “Don’t contribute any gold” for now. But frankly you know that’s not really an option when you’re in a guild. There are expectations to meet! Places to go, people who you don’t want to disappoint.

@morose The disappearing Tribute thing is showing up on the PC/iOS version too. Though it’s only happened a couple times so far.

I didn’t follow your comment about “lower than 10%”… I’m NOT referring to getting no tribute at all. My observation is that the Tribute icon was already present and flashing but, after checking Mail or briefly entering the Guild menu, the flashing icon simply disappears off the Map. :weary:

Why is this still a requirement in guilds!? Using seals to track is so much better especially since the requirement does not need to be that large.

What? Gold? Why wouldn’t gold be a requirement still? Most mid to high level guilds have weekly requirements for gold, seals and trophies. A lot also require that cities be completed to level 10. Some even require certain VIP levels, if I’m not mistaken.

That might be true for casual guilds but not for non-casual ones.

You can get 1500 seals by just doing explore, maps or arena. In other words, the production of 1500 seals does not necessarily equal the production of the 533,000+ gold needed per person to max out basic guild tasks.

That doesn’t even take into account legendary tasks.

3 Likes

Yeesh. I hadn’t actually thought of it in breakdown terms, but you definitely generate most of that while climbing the PvP tiers, as well as a hefty chunk just from Tributes from leveled cities.

To reiterate the issue with weird server stuff happening with Tributes, this afternoon while on my iPad I was rearranging teams in my Troops menu when the hourly Tribute triggered. Suddenly, the “News” splash screen (showing Wulfgarok) popped right in the middle of my trait levelling screen for Flesh Golem.

Not only was this disconcerting, it’s another indication that gremlins are now throwing a wild party inside the server and they’re wreaking havoc on my nerves.

1 Like

I have had the tribute icon disappear also. Sometimes it doesn’t show up at all for me. If I click on my home kingdom I still get the tribute though. Have you tried that?

I’ve got the contribute error also. I think it has always happened when I try to donate after getting the message that someone has already completed the task. The only thing that has worked is to quit and restart the app after getting that message.

1 Like

Hola! It never occurred to me to click on my home city anyway for a missing Tribute! Thanks @Athrillskr, I’ll have to try that.

So… if this is true it’s a graphical glitch then… which apparently is occurring across both PC and console versions. A graphical glitch might also explain why a force quit and restart could sometimes pop the Tribute icon back into existence, but not all the time.

In this case the (visual bug) issue may also be related to what @Shimrra reported four days ago in Income/Tribute Collection Indicator Gets Jumpy:

1 Like