Serve and Protect with +10 Affixes does not give the Hero Barrier


#1

Platform, device version and operating system:
PC, Windows 10
Samsung G6, VS988 Rev. 1.0, Android 8.0.0

What you were expecting to happen, and what actually happened:
When I cast the +10 Serve and Protect ability I expect for my hero to gain barrier because the Shielding affix has been unlocked, but I do not see any of the indicators that a barrier is active on my hero and when an enemy deals damage to my hero it is not blocked.

How often does this happen? When did it begin happening?
This has happened every time I have used Serve and Protect since I upgraded it.

Steps to make it happen again
Fully upgrade Serve and Protect, equip it on your hero, enter a battle, charge the weapon up, cast its ability.


#2

For me it does work



#3

Ok. This is what it does for me.


#4

Image #2


#5

Image #3


#6

I’ll try it in a minute with that same team, maybe it’s bugged when it moves to first slot

Edit: @Wesmerized appears that this ^ is the case. If it moves to first slot it doesn’t give barrier

Edit 2: here is the video of it in painful 0.25 speed :smiley:

seems that it’s giving the barrier to the slot hero was in before he got moved to first slot, so the new second slot got a barrier twice

@Cyrup, @Kafka you should report this


#7

Thanks for testing that. I just tried it and you are correct. If my hero is in 1st position when activating Serve and Protect’s ability, then my hero does get barrier as expected.


#8

Thanks for bringing this to our attention!

I’ll let the team know.


#9

Hello,

I have found that this same bug affects the Guardian Crown also.

wes


#10

Confirmed. Guardian Crown +9 is also affected by this.

@Kafka


#11

Thanks, that’s correct because it’s the same Affix effect and spell ability combo (barrier + change position)