Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[Reported] Scrolling missing from CoC weapons

Steam, windows 10

Cant find the new event weapon, String of Teeth, in the event weapons.

Its not in the unowned weapons either


But when i rearrange the weapons to rarity it shows up

So the scroll arrow and ability to scroll in missing in Steam version

Try rebooting the game. The game can be funny about weekly resets and things like that when hidden content has to be turned on.

No scroll bar on Android, but I can move the weapons list by dragging it. Have you tried that? Click and drag up? Or try scroll wheel.

Still, scroll bar should be there, thanks for reporting it.

1 Like

I agree, the scroll bar should be there. And the arrow.

I play on Lenovo and use trackpoint mouse /the joystick thingy, in the middle of keyboard) exclusively. So scrolling like on normal mouse is not possible. After few tryes i was able to get the dragging of weapons working, but its not really natural move on my setup.

Its not that, scroll down is just missing entirely when setting a kingdom filter for weapons specifically. Happens in and out of the event, for every kingdom. Not sure if this is a new bug or not, never paid attention before now.

drag down to

or (filter Broken Spire weapons)

drag scroll to

Dragging back up also makes the scroll arrows disappear again.

Actually, it appears to be any set of filters where you have exactly 9 or 10 options available. The scroll bar won’t show until there are 11 items to show. Almost like the calculation to see if scroll bars should show when scrolled all the way up uses the assumption that there are 5 items per row, when there are in fact 4, but every row beyond that seems to correctly use 4.

Example:
Filtering yellow-red combination weapons on an account missing two yellow-red weapons (has 9, no dawnbringer or fleshripper):

Same account, but setting the filter to all weapons (11 weapons total with this color combo)

An account that owns 10 of these weapons (no dawnbringer) still doesn’t have the scroll bar.

Same thing if you set the filters to get exactly 9 or 10 different troops:

TL;DR: Any combination of weapon or troop (and possibly even pet) filters that results in 9 or 10 results will result in the scroll bars being absent when scrolled all the way to the top. 11 or more results has them show correctly. The scroll bar should appear starting at 9 items. Suspect the check to see if the bar should appear while all the way at the top uses the wrong value (> 10 instead of > 8, or assumes a column width of 5 when only 4 are displayed). Does not appear to be an issue for any page past the first page.

5 Likes

Thanks Mithran! You are a real gem!

Found another: Filtering for anything that produces exact product of 4 for anything greater than or equal to 12 results in the scroll down arrow being visible when there are no more results to be displayed. This scroll arrow is non-functional when on this page, but dragging allows an additional half page of blank results to be loaded.

Adana/Not Brown produced exactly 12 results, bottom page looks like this if you use the arrows to navigate:

Using the mouse to drag the screen allows you to move into the empty row, which makes the scroll arrows disappear:

The same occurs for a set of results that produces 16 (bright forest, not yellow):

The same occurs for my account that has exactly 804 troops owned, with no filters set:

(again, can’t use arrows to scroll past this point, have to drag)

This is likely the result of a classic off-by-one error. I’m not sure if it is intended to scroll when to a page with exactly 4 results (top half full, bottom half empty), but you definitely shouldn’t have a non-function scroll down arrow at the bottom of any multiple of 4 item results, and the functionality should be consistent on whether or not you are allowed to scroll to this position or not.

Also, both this and the error mentioned in the earlier post do apply to pets filters as well.

2 Likes

This is also affecting Xbox, can confirm. If I search by “Upgradeable”, neither RT or LT work anymore to make the scroll jump

1 Like