[Reported - more info please] New Merchant popup is overtaxing GPU

Steam, v6.8.0r43736, Windows 10

Screenshot or image:

What you were expecting to happen, and what actually happened:
Left the merchant popup on my screen for a few minutes, but then noticed my fan speed on my gpu ramping up to full. Checked gpu utilization on my RTX 3080 and it was peaking over 80% (general level is around 30% for this game) and temps were up around 80C (usually around 40ish for this game)

How often does this happen? When did it begin happening?
Have tested it a few times now, and as soon as the merchant screen pops up the GPU utilization and temps spike. Exiting the screen brings both down to usual levels

Steps to make it happen again
Basically encounter the merchant/daemon/genie/angel and check task manager’s performance tab - easy to see.

i see this too im runing a 2070 Super and hitting 87% on merchant screen

Haven’t tried on Windows yet, but on Android I turned on the OnePlus gaming status overlay and: GPU usage maxes out at 99% on the merchant screen, but also: on kingdom overview screens; at the explore difficulty select screen, and at the explore battle select screen. It’s more reasonable, circa 10%, in-battle and at the explore rewards screen.

(Android 10 on a OnePlus Nord N20 5G)

Might be worth checking Windows GPU usage on these screens also?

As for Switch, (which doesn’t exactly have any live performance tools built-in to verify this with) there does seem to be an odd momentary delay any time one of these offers pops up.

It’s def noticeable, I have a lot of settings on med or low and it’s still noticeable on my GPU usage graph, probably some unoptimised render in the background maybe.

Hi all we’ve notified the dev team about this.

If you haven’t already can you please provide your device model (for mobile and if you’re getting it on a console) or GPU model if you’re on PC?

Hello! :slight_smile:

It looks like the blur shader is causing this issue.

To fix this, please turn off the blur effect in the graphics tab in the settings menu.

1 Like

This has alleviated the issue somewhat - there still is a bit of an increase but nowhere near as drastic. Thanks!

Technically speaking this is a “workaround”, but whatevs.

Eh, I've seen worse

There was a time where GIMP, that free image editor app, had a serious bug crop up between versions where any time you attempted to use a graphics tablet with it (which is one of its main features) resulted in ridiculous system lag any time you moved the pen too quickly (aka. all the time). It took over a month to determine and fix the culprit, but in the meantime a workaround was identified: the bug was related to the rulers shown on the sides of the window, so any time you turned them off the lag vanished and the program performed correctly. The cause turned out to be a “cascading event” type of recursion occurring in the “ruler” UI element when paired with the high input rate of a graphics tablet. It was fixed by marking the ruler for a standard UI refresh later instead of manually invoking a UI refresh (potentially while inside a UI refresh itself).

BRB while I test this toggle on Switch and record video with and without. (Apparently the default setting is “Low”?)

  • “Low” setting: got it (Genie)
  • “High” setting: got it (Angel)
  • “Off” setting: got it (Genie)

Okay, I’ve got the videos recorded.

In Portable mode, there was a noticeable difference in framerate between “Low” (default) and “High” settings but that was hardly surprising.

Does enabling the “Power Saving” graphics option help?