[REPORTED] Guild Task Reward issue

Platform, device version and operating system:

Screenshot or image:

What you were expecting to happen, and what actually happened:

this is actually happening to one of my guildmates, Bloody Cross, I’m reporting this for her, we expected to receive all tasks rewards, but instead, some rewards shows that it has been claimed in another guild, which is funny because she has been with us for more than a year.

How often does this happen? When did it begin happening?
i think it happens only once

Steps to make it happen again
no idea, i didnt experience it on my account

and the screenies exist, please just click on the link to see the error

I am having the same issue, says i have collected rewards in aother guild, i have logged in on Android tablet, logged out, tried ios phone, same message.

1 Like

Hey all,

If anyone is experiencing this, please send through a Support ticket and I’ll go through your mail logs to check!

In some cases, the rewards are successfully coming through still but there is a small handful of people who have missed some items. More than happy to check!

Jeto - Support Human :woman_mage:t2:


Sent in a ticket earlier, have not tried to collect rewards


@Mariana that mail is completely safe to collect in the meantime, it will make it easier for one of the team to go through your logs if you do :sparkles: