Please allow us to disable enemy spell slowdown when selecting a troop

It is incredibly obnoxious that the game slows down when the enemy is doing its turn and I am queuing up my next skill. Can we please have an option to disable this so it always goes at the game speed it is set at?


I raise:

Can the devs just disable it entirely and not even give us the option, maybe?

I mean I can see why some might be able to use the option buuuuuut I also really don’t think anyone is going to mind not having it.

I think an option is not necessary because this is clearly a bug. Let’s correct the bug. The game must stay at correct speed, even if we are preparing our next cast.

1 Like

I think it was either @Kafka or @Cyrup that said this isn’t a bug.

i think someone said it is too hard to change so now it is a feature

Still, it’s annoying at best. However, it’s not the biggest issue at this point in time.

Ozball said on a recent(-ish?) stream that there are technical reasons why it hasn’t or can’t be done – if/when I care more I may go find it :stuck_out_tongue_closed_eyes:. Sucks.

they can name it other than ‘bug’ but it’s still the same for me. If it’s a choice, that’s pretty … let’s say stupid ^^