[Not a Bug] Animation Speed

when you wait for the enemy to finish his turn, I learned that you can click cast on the unit you want to use next, and the button will turn white when it becomes your turn again.
I run the game at x4 speed, and while you wait, its no longer x4 anymore. Its closer to x1 or perhaps x0.25.

I hope this will get changed, so I will be able to enjoy this new feature.


yes, is see and do this too
i like it, that the gemcounter changing right and that the castbutton goes green when its my turn, only the “slowmotion” in the background is annoying

I think, animation speed must be one for all system events! I’m many times tap on unit until enemi still make actions and need wait long time and see this “slowmotion” or close dialog.
This behavior annoys me very hard!

Hey, this is working as intended but I will pass your feedback along.

If you have any more feedback please post it to the feedback section of the forum

This is bug. If I wanted to play at a speed of x1, then I would use the appropriate setting. But I want to play with x4 speed. It annoys everyone with whom I spoke on this subject.