PC Steam Event Souls


#1

What you were expecting to happen, and what actually happened?
I claimed my souls the first event and I did not get them. It says complete
What are the steps to make it happen again?
How can I get them or what can I do ???
Do you have any screenshots or video you want to share with us so we can see the problem? Attach them to your post!


#2

Is this the 10p Souls reward? Have you gotten any of the later ones?


#3

I watched today, and did not get the 1,250 souls for the 50 event gem milestone.

Normally, when you claim one of the prizes, there is an animation showing them awarded. I did not receive any animation.


#4

I saw a few others discussing this in chat so I checked my souls before and after claiming it and I didn’t receive mine.


#5

I can confirm, I just now collected the 1250 soul reward and it wasn’t added to my inventory.


#6

I didn’t get a reward popup after claiming the 10p souls reward, but I didn’t bother to check if I actually got them or not. So I got video proof of the 1250 souls reward not working.


#7

Hey Guys,

Thanks for letting us know, we’ll take a look and see what’s happened.

Big thanks for the video @Mithran, super useful for us to show the team.


#8

Hey guys,

We’ve put a fix out so Souls rewards should be given out correctly in the future. Unfortunately it won’t give out the souls to anyone who has tried to collect them already.

If you have collected the souls and didn’t get the rewards. Please contact our support team here: https://gemsofwar.zendesk.com/hc/en-us/requests/new


#9

Tried to collect 1250 Souls just now (Android). Didn’t get them this time either (checked my Collection before and after). Will use your provided link to support.