Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[Investigating] Game Won't Load

Platform, device version and operating system:
PC & Mobile

Screenshot or image:

What you were expecting to happen, and what actually happened:
I was trying to load the game, but just hang on the loading assets screen

How often does this happen? When did it begin happening?
began at weekly reset. still ongoing

Steps to make it happen again
close game, open game

6 Likes

yep same here. Stuck on loading screen

Confirming the issue on Steam / PC. It just won’t load any assets.

I have the same issue …

hanging at same spot (e in assets)

Thanks for letting us know. I have also posted in the other thread regarding this issue, stating that we are looking into this and a fix now.

5 Likes

Same here. Tried to reinstall, followed steps: https://gemsofwar.zendesk.com/hc/en-us/articles/203464985-I-m-on-Steam-and-the-game-has-connection-errors-on-startup
Still not working. Glad to see this post, seems it’s not on my end after all.

Same, restarted everything but still hangs when “Loading assetts”
Progress bar gets further on mobile but stilkl doesn’t load

PC Win10 x64 19041.630
Android 8.0.0

I’ve made an article if anyone wants to follow it to be notified once the issue is fixed, or wants to link anyone else:
https://gemsofwar.zendesk.com/hc/en-us/articles/360002183496

5 Likes

The issue should be fixed now, we will send a little compensation out tomorrow during business hours.

3 Likes

Thank you, that was really quick! Now let’s check out the new week :smiley: