Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[Reported] Game stuck on loading screen on PC/Mobile

Platform, device version and operating system:
PC/Mobile

Screenshot or image:

What you were expecting to happen, and what actually happened:
I expected that the game would start as usual, but it get stuck at loading screen.

How often does this happen? When did it begin happening?
Whenever I try to launch the game. It started 5 minutes ago.

Steps to make it happen again
Simply try to launch the game.

3 Likes

PS4 is also broken. It hard crashes (error CE-34878-0) when the Loading Assets bar is almost full. Were new assets just pushed a few minutes ago?

1 Like

Same here for mobile. Tried to log in to get my last tribute before going to bed and it just hangs without connecting or going to the kingdom screen.

Went to collect tributes, and game froze on both Both Mobile and steam, Now game doesn’t even load.

Back up, but looks like I may have lost tributes

I can’t play my morning coffee games, this is going to be a horrible day :cry: I need some comfort gems as compensation :pleading_face:

1 Like

1 Like

Trying to launch at my mobile the loading bar gets full, but nothing happens.

Whew. I thought i twas just me. The “Loading Assets” bar is all the way across now, but it still isn’t loading. I can’t collect my rewards.

Is this related to a new release coming? I’m still wondering what the WyrmRun traits were that I never got to see.

(PS4) Game just downloaded a small amount of data at launch, and it works again. Try now?

1 Like

It’s up again for me.

1 Like

Steam, and android same. Cant login.

Fixed on mobile (iOS) now.

Edit: Disregard, just another hiccup or something.

Lmao, it worked as soon we made the posts xD.

1 Like

haha yeah, patient young padawan lol

1 Like

Good thing we didn’t panic or anything when the game was down for few minutes :joy:

3 Likes

Hey hey!

Thanks for bringing this to our attention. I’ve looked into this can see that we experienced a server issue at the time this was posted.

The Dev Team were aware of the issue at the time and acted to get this corrected so you should no longer be experiencing this issue :slight_smile:

OminousGMan - Support Human :male_detective:

1 Like