Grave Knight stops play


#1

Does anyone else have a problem with the Grave Knight?

It stops the game dead after it fires a spell and I have to reboot and reenter. This happens in challenges and the arena in any configuration. I haven’t tried it in PvP as I don’t want the defeat. The support team says that they cannot replicate this but I find it hard to believe that I am the only one with this issue.


#2

Yes, we’d be curious if anybody else has this problem.
We’ve tried dozens of games and configurations here in the studio, and we haven’t been able to get it to happen once.
Any help/insight anybody has would be VERY appreciated!


#3

What platform are you experiencing this issue on? (e.g. PC, Mobile, Xbox1, PS4?)


#4

Mobile, specifically iPad mini


#5

I’m I can try on iOS. What traits/level does it have so I can add them?


#6

Additional bits of info that could help if you’re willing to provide:

What version of iOS are you running?
Have you tested the spell on an enemy without armor?
Does the same crash occur when the enemy fires the spell? (Have you faced an opponent with the troop?)


#7

IOS 9.2.1

No traits (why would I bother) as I try to avoid using it. Only Level 6 for the same reason. But it also happens in Arena whether on my side or the enemy.


#8

No I haven’t tested it without armour. Use either dragon or celestial. Will give it a try with none to see if that makes a difference. It definitely happens when the enemy fires in the arena. That’s when I first worked it out. Initially I thought it was a memory problem, but then I noticed it only happened with the Grave Knight. Thought it might get fixed with the last update so I tried using it again but it still happened.


#9

So I tried a challenge with no armour at normal difficulty and it still happened.


#10

I also play this on an iPad mini (2) and am on iOS version 9.2.1. I just did an entire arena having my team revolve around the Grave Knight. In other words, used it lots of times, also on opponents who didn’t have any armor remaining by then. No crashes.

Did you try reinstalling the game yet? Is that an option without losing progress, actually?


#11

Yes, though it’s recommended you link your account to get your passcode first, just encase cloud sync doesn’t work. If you got your account connected email and passcode, you can safely connect to any mobile or PC device.