Flash offer bug (Fixed)

paid for 1 flash offer… Came up with an error code… Then it forced closed game…
It’s taken money from account but I haven’t received the offer.

I confirm, I have the same

Me too. And quite a few others that are in the xbox chat javent gotten thiers either

Same here on PC/Steam

Me too :pensive: - I was about to put a ticket in.
iOS iPad
No purchases received - just a Cliffy error after the purchase acknowledgement

Pareil , j’en ai acheté 3 et reçus aucun …


Dame issue here
Tried twice, got the same error message, funds were captured but I got no gems or vault keys. Attached screenshot from Google Play

If it comes in your in game mail later on. Please make sure you don’t collect it more than 5 times. :grin:


Thank you Kafka & Devs - I have now received my Flash Offer via mail. :grinning::+1:
I did not need to put a ticket in after all.

Hey the issue is fixed with the Flash offers now and mail has been sent to the game mail of the players who were affected.

Your VIP Points will be added to your accounts on Monday.

If you are still missing rewards from a purchase please submit a support ticket with a copy of your receipt so we can fix this up for you on Monday morning (Australian time)

Here’s the link to send a ticket:


Thanks for the update on this kafka :slight_smile:

Ils m’ont remboursé que 2 achats sur mes 3 , j’ai envoyé un autre message , j’espère que le problème ne persistera pas par ça que j’aimerai acheté les 2 autres qui reste dans l’offre mais je n’ose même pas là maintenant

Hi Kafka, I am still waiting for my ticket request reply. You said you will get to my ticket in a bit this morning, but after one day waiting, until now I got no response, request ID#71434.

@kusogod the team is out on the weekend so if you weren’t given your mail they said they would answer the ticket on Monday or Tuesday where they’re back in the office depending on their workload