Bug with Flash offer 22nd of March

Kavka suggested in the global chat to open a support request, I believe it was for here.

samsung S8, Android 9.0 Pie

Screenshot from google play

What you were expecting to happen, and what actually happened:
Clicked to purchase 100 gems and 1 vault key from Flash offer.
Got Google Play popup and confirmed transaction.
Popup changed to confirmation.
Popup was replaced with error code from the game.
Funds were taken from the credit card, not gems or vault keys were received. Tried this twice.
Expected was to receive 100 gems and 1 key per trnasaction.
Actual was to receive and error both times, funds were captured and no reward was given.

How often does this happen? When did it begin happening?
I tried 2 times and got the error. Screenshot from google play. Funds were captured for both attempts. Kavka was online in the global chat and we identified that this is an issue with game or promotion.

Steps to make it happen again
Repeat what was described above.

I had the same from android, sure will be fix from support.

I had the bug on PC with Steam too.

Hey the issue is fixed with the Flash offers now and mail has been sent to the game mail of the players who were affected.

Your VIP Points will be added to your accounts on Monday.

If you are still missing rewards from a purchase please submit a support ticket with a copy of your receipt so we can fix this up for you on Monday morning (Australian time)

Here’s the link to send a ticket: