[Fixed] Old team for epic trial still showing up


Screenshot or image:

**the epic trial team for stormheim was supposed to be replaced with a new team at reset. However i still have the old team set up of fomorian, stormknight,etc

Loaded in at reset after reading there was a new team for epic trials. That wasnt the case.

Loaded into game. Closed game and loaded back in and still had the same old team in epic trials. Shut down console and started back up and had the same problem

1 Like

Reset your console.

Im on xbox all 5 epics done, easy this week.

1 Like

I have, still have the old team.

Edit: Funny enough, I have the modified “Theme” guide, but still have the old team.
Edit: Deleting and reinstalling the game did not do anything.

1 Like

Did reset the console. Same team loaded in for the epic…

1 Like

Not me but another player in global also having the same issue

1 Like

I am seeing the old teams on PC. I have restarted the game and checked on PC and Android.

Other players are seeing this too, see Big Boned.

My guess is that it depends on whether players had done any regular trials using the original team. I had. I presume that copies a template team into a hidden slot on the player’s profile to permit reordering.

[update: My hypothesis is incorrect, Awfuldevs provides an example that disproves it in the next post]

1 Like

I used the old team yesterday to get ready for epics today.

Thdn when i started today i had the new team.
No problems on xbox here.


While I’m waiting, by epic trial 4, Fire Giant is hitting for 100 damage and Jarl is hitting for 101 damage.

Edit: epic trial 5, FG is hitting 115, Jarl is hitting 116.

The old Trial team is so hyper fragile in this situation. This team is really bad…

Edit: got lucky on epic trial 5 with the old team. Storm Knight upfront got like 3 skulls in 10 seconds on their Frost Giant. hah. Survived with only 2 troops, 1 was 1 shot range, the other was 2 shot range.

1 Like

I am also stuck with the original team. Ive unplugged my xbox, reset xbox, reset game (all several times) and still not fixed.

1 Like

Same issue here on Steam & Android.

1 Like

Same issue, also on Xbox.

1 Like

I also still have the old Trial team. I’m on Xbox and I did complete trial 9 and 10 last week.

1 Like

I have the new team; my wife is stuck with the old one.

The only difference I can think of is that she was doing regular trials until she got to the epic ones. I had already completed my challenges in Stormheim before the new trial mode was introduced. My wife was doing the trials last week.

1 Like

Platform, device version and operating system:


What you were expecting to happen, and what actually happened:

My wife has been doing the trials in Stormheim, and now has reached the epic trials. I completed several of the epic trials already, but with a team that has a prayer of beating the enemy: Skyrmir the Lofty, The Sapphire Giant, Valkyrie, and Hyndla Frostcrown. My wife however has been forced to use a completely different (and completely worthless) team: Fomorian, Flame Maiden, Storm Knight, Zephyros.

The team that’s been foisted on my wife is not only bizarre, but has none of the abilities listed in the Hints for these battles:

  • Freeze Enemies to prevent them getting extra turns.
  • Summoning can refill spaces where your troops have died.

Those hints apply very well to Hyndla Frostcrown, but the troops my wife has been given to use don’t have these abilities at all.

It’s my understanding the trials shouldn’t be based on what troops you have, but she isn’t missing any of the troops from my list. The only ones missing for her in Stormheim are the four Frostfire faction troops.

How often does this happen? When did it begin happening?

This happens every time she goes to start a trial. Since completing the 10th regular trial (I had already completed the old challenges), she has tried closing the app completely and reopening.

So you can check this on your end, my invite code is ALDIN and hers is LEMUR998.

1 Like

The team for Stormheim trials has been changed (to the Hyndla team), but many players are still stuck with the old team (the Fomorian team) for reasons unknown. See the bug report at Old team for epic trial still showing up.

1 Like

Hello, :slight_smile:

Thank you for the screencaptures and also for stating what platform everyone is encountering this issue on.

I’ve let the development team know about this issue with the trial teams!

1 Like

I have the new team (I’m on Steam), whereas my daughter has the old team (she’s on Android through Google Play).

Hello everyone :slight_smile:

Just an update that there should be a fix for this issue rolling out in the next 24-48 hours.

Please make sure to restart your Gems of War game completely and ensure that you have all latest updates to ensure that your account/device does receive this fix.

If this issue has not been resolved for your account after the next 2 days, please send us a support ticket with your Invite Code and Platform. :slight_smile:


I can confirm the issue is resolved for me on both Steam & Android. Very happy with the quick response by the devs - much appreciated!

Fixed for me too. Thank you.