Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

Error accessing the "Offers" menu item

For the last few days I’ve been unable to access the “offers” menu item. I’m getting an error code of 2622-1502. Is this a known bug? Are there any fixes?

Thanks

I’m a brand new player and I am also having this issue, any advice would be appreciated.

I’ve noticed this on my Switch as well. Are you both Switch players?

On my PC/Mobile account I don’t have this issue.

Yeah, switch player here.

Also noticed that I am unable to find the Death knight armor as well. Dragon is just the last on the list.

I noticed the same issue on my switch…error 2622-1502

same error code on offers, and my global chat seems to have totally stopped working?

Are you guys (devs) supporting your switch version???

Yeah, mine says the servers are working normally and to check for scheduled outages or w.e.

I’d like to purchase a couple of the P2W items from the shop, but apparently I’m unable to.

Setting it just being broken aside, is it possible that maybe it has to be unlocked via a “uther tutorial” feature.

EDIT: I have submitted a request to the support team about the issue, I’ll keep this thread updated if I get a solution/response. Due to an abnormal amount of support issues, it supposed to take more than a week to get a response. Hopefully they get to me sooner.

Have you tried restarting the game?
I don’t have this issue. Switch player - of course. :wink:

Restarting / Using different network – Neither worked.

This should not been an issue since there is a Switch Error Code. The only problem is how long the dev here can notice the problem and dig into it.

@Cyrup @Saltypatra Switch users can’t buy stuff from the store.

Hey,

Thanks for reporting this! Unfortunately this is a known issue currently affecting all our Switch players in the North American region. 505 Games are currently investigating the issue.

If you’d like to be notified when there’s an update to the issue you can follow the Help Centre article here:

Thanks for the update. Does this mean that if I change my account to another region can solve this problem? Thanks.