Error opening "offers" menu item


When clicking the offers menu item I get an error code of 2622-1502. The details page redirects me to nintendo’s site but nothing comes up when searching the error code.

How often does this happen? When did it begin happening?
This happens ever time I click this menu item. e.g. Was this a once-off bug or has it been a consistent issue? Does it only happen after doing a particular game mode?_

Steps to make it happen again
On Switch - Click the offers menu item on right column. e.g. Sometimes there are certain steps that can lead to a problem that may not be obvious! Example: I lose once in the Arena, I then exit to the world map, select broken Spire on the Map and enter Arena. broken spire’s quest lost instead._

This used to work properly, I bought the ring here (can’t remember name) and used this to watch the 28 day countdown. I was considering buying the ring again but can’t due to this bug(?).

I have tried shutting down and powering up my switch, deleting and downloading the game again. None of these worked.

Thanks in advance for any suggestions.