Critical issue: Battles or purchases are often not updated in real-time in most cases

Platform: PC, Steam client
Game version: 4.3.5.04 (bug was introduced since 4.3.0.07 update)
Game language: English
Operating system: Windows 7 (64-bit) Home Premium Service Pack 1

What happened?
This is an old issue that only started happening since the 4.3.0.07 update was first released.
Game progress is not properly recorded in real-time. You often must switch or click on another part of the interface and then return back to it to see the change that should have happened automatically.
This can also cause strange messages and errors when it happens if you repeat the battle that you already completed. If you check the video, you will see what the problem is.

The ONLY SOLUTION is to immediately restart the game and hope that it will not happen again.
There were no connection or other ISP-related issues, so this is something that’s happening in the game.

Video: (example shown here)

(Battle Stage 2, 1st battle started, but I was still seeing Stage 1, battle 5 in the menu, Rewards, etc.)

This is linked to all the following events:

  • Pet Rescue Events that were completed were often not marked or checked when in the battle menu screen for all 8 battles or after a complete battle (real-time).

  • Shop Tiers upgrades that were bought were not updated to indicate that you purchased that item at tha time. The only solution is to change the interface and then click back on it again to see it as you should.

  • Same goes for the Disenchantment screen - Troop cards that were sold, were not properly updated in real-time.

  • Invasion / Raid Event / Reward screen

  • Weapon upgrades screen. (error message)

  • Troops screen or leveling screen. (ascensions, level up issue, restart is needed in such cases)

Additional notes:

  • This also applies to Delves and the Store or Reward section there, and the Trophy upgrades!
    Here’s one example:

Screenshot: (I bought 5 purple trophies, but the count did not decrease, deduct.)
When I tried to do the same, I was greeted with an error message.

  • This also applies to the Class Event and the Reward section - Assassin (as shown in a video)

  • Unsure about the other events, but I suppose it’s the same issue and probably happening.

  • Hopefully, no Sigils are consumed when it happens.

  • If you get this issue in the Shop, you will get some kind of error message.

  • Keep in mind that you may not get the error messages in all cases.

How to replicate this bug: (it may not be related)

  • Play the game for a while, while doing Pet Rescue Events, Explore Battles and PvP (Ranked battles), then try to play the Class Event - (estimated time: 1-2 hour/s)
1 Like

I would ask @Kafka or @Cyrup to comment on this, regardless of a new updated policy.

Also, I forgot to mention above that this issue also happened once or twice in the weapon upgrades screen. This must be a general issue that causes all these things, not an isolated one.

@Kafka
@Cyrup
Okay, you fixed the issue, but I am still getting the issue when the event won’t be properly updated in real time. I often need to select a different section or even exit the game.

Examples:

I ascended a troop from Level 19 to 20.
The statistical window for 4 attributes did not display any statistics. It was without any animation.
I was still able to close it normally.

Pet Rescue event will no longer display error messages, but it will occasionally still not immediately update the battle (check mark) when it’s finished, the interface section.

Same issues goes for Guild Statues. I had to re-enter the screen to see a proper Legendary Task window after all the statues were fully upgraded.

Same goes for the Guild Seals. Using a Clan Orb or a Major Clan Orb, will not instantly update the number of Guild Seals, but you will have to leave the interface and get back to it.

Same goes for the Event Rewards. Often the reward, let’s say no. 10, will not get instantly checked, window or greyed out, so that you can’t click on it again. The only solution is again to revisit that section.

It’s seems that the game have some troubles when updating events that occur in real-time - the interface. At least the error messages are gone now, but it’s still not as it should have been or like it once was.