Fixes Going Out Today (Faction Pets, Vash'Dagon & Spell Text)

Ahoy adventurers, we have put out a few fixes today.

  1. Faction pets will now show up in unowned.
  2. We have released a Vash’Dagon fix that should resolve instances where it freezes the game.
  3. We have reworded the spell text for Knight Coronet and Giant Crab to better reflect how their spells work. This change explains that they can deal damage twice to the last enemy.

New Knight Coronet Spell:
Remove all Purple Gems. Deal damage to the first Enemy, boosted by Gems removed. Then deal the same to the last Enemy.

New Giant Crab Spell:
Deal damage to the first Enemy and then the last Enemy. Then switch them.


Aw, title made me think you were going have him curse so he could devour allies through immunities or at least get a hidden dispel like Black Beast so he could devour allies with bless/barrier. But not crashing is good too I suppose.


Princess Elspeth also has this hidden dispel, which even lets her kill Towers in the active weekly event. :crazy_face:

Curse by itself would not allow transformations/devours, right? Wouldn’t you further need to Stun to negate the Invulnerable trait?

Princess Elspeth does have a hidden dispel, but the reason she can kill towers through invulnerable is because she has a type of instakill spell that isn’t flagged as lethal damage and therefore isn’t blockable by immunities, like every ally or self kill spell (and Boss Zuul’Goth).

Also, curse is actually completely blocked by Invulnerable, unlike Impervious (so stun wouldn’t ever land on that). Curse alone is actually enough to bypass devour immunity, both impervious and indigestible (it negates all immunities, including mana drain and mana burn, even though they aren’t statuses). It wouldn’t cover transforms… because theres no transform immunity trait except Invulnerable, which can’t be cursed. If Vash’Dagon got hidden dispel, curse, then devour, it would cover the entirety of his summon pool, and allow him to be used with troops that grant bless/barrier. No more Gargantaur getting summoned and stuffing your (already kinda bad) combo. No more Divina throwing out a random barrier or bless on your devuor target and making it so you can’t use an already barely present synergy. It’d be on you if you stick a Doom in your team knowing you can’t devour it.


Black Beast is more valuable than Vash’Dagon, because of a hidden dispel spell.
In short, the Ultra-Rare troop is more valuable than the Mythic one because of this.
Why are developers not reading or taking into consideration the input they get from us?

1 Like

Because they dont have-to/ want-to read the boards anymore?

Because every time they run the numbers they’re doing better than before, and nobody quits.

And it’s not like they never listen, but we have zero transparency around their plans or priorities. For all we know there’s a better Vash fix coming but it requires a client patch. Technically they hadn’t even acknowledged they could reproduce the freeze yet. And nobody knows why these two troops got a rewording out of the dozens who have text issues.

One time I had a dev posting jokes in my thread at least a month before another dev responded, “this is a Unity issue, we have to wait on them”. Their ways are mysterious. Most of the time we don’t know if they even read our post. Even if we know they read it, we don’t know if that means they’re prioritizing it. Even if we know something has some priority, we don’t know what priority that is. Sometimes they agree the thing we report is an issue, but want a wildly different solution than we asked for.

We discuss our issues and priorities with each other, and explain why we think this is more important than that. Sometimes we even agree. Devs don’t participate in that so they feel more like stubborn gods who sometimes answer prayers in a way that makes us wish we hadn’t made them.


@Kafka, @Cyrup and @Saltypatra
I am really disappointed. This is a bit off-topic, but I wonder if you really don’t read this Forum as precisely as you once did.

I just checked the List of Known Issues and the most annoying bug IS STILL NOT listed.
It’s the one when the interface (general issue) won’t update during the Pet Rescue Event, Guild Tributes, weapons, etc. It’s affecting the whole game management system.

Hey @Koromac , it was on the list, I removed it as we believed it to be fixed until recently.

1 Like

Well, I know that it’s a visual issue only, but yeah, it’s still happening, especially if you enable and then disable the chat. It may be connected, but I can only speculate at this point.

Also, it’s not affecting the Pet Rescues, but all the Interface operation, from weapon upgrades, trophy screens, statistical screens, pretty much everything, so don’t think that this issue is isolated only to PR.

I hate sunbird casting a spell and returning as a bandit. So freaking aggravating

This forum aint to large, so i do believe that there is a person whos job is to read everything, and the rest of them reads only what interests them.
But talking with every player about every opinion we have just isnt going to happen.

1 Like

It’s not a bug, though.

Did this fix somehow not make it to iOS yet? (It sounded like a data fix; no app update required.) I just now had the game freeze up on a Vash’Dagon cast. Enemy team had a Kerberos left, which summoned off my cast.
Here’s a screenshot of the frozen game:

Please go to Settings —> Privacy —> Analytics —> Analytics Data. Is there a file titled “gemsofwar-2019-08-*******” corresponding to this event? If so, what does it say for “Exception Type”, and what was the thread doing that triggered it (look for “Triggered by Thread” and scroll down till you find it)?

I just submitted a bug report about something similar, and I want to see if my suspicions have merit.

Edit: also, can I assume you had the game at 4x animation speed?

Yes it was 4x speed. Today’s file is gemsofwar.cpu_resource_fatal-2019-08-16-162302.ips
It was killed due to using too much CPU. Probably got stuck in an infinite loop in the logic.

Event:           cpu usage
Action taken:    Process killed
CPU:             48 seconds cpu time over 49 seconds (98% cpu average), exceeding limit of 80% cpu over 60 seconds
CPU limit:       48s
Limit duration:  60s
CPU used:        48s
Duration:        5.01s
Steps:           5

We should tell @Kafka and @Cyrup that this issue is still not fixed then.

I just had an interesting experience with a game “freeze”.

  • Mid-battle, I backed out to the iOS home screen, turned on the flashlight, and plugged in my phone.
  • I returned to GoW and found it to be completely non-responsive. No animations, no reactions to screen touches, nothing.
  • I backed out to the home screen again, and returned to GoW again.
  • Game was functioning fine again, like nothing at all had happened. (I won the match. :+1:)

If anyone else reads this and has the game lock up on them, I will be interested to hear if you can resolve it as simply as I could.