Adventure board "upgrade Sea of Sorrow to level 5"

Adventure board “upgrade Sea of Sorrow to level 5”

What does this mean, can you tell?




Maybe it’s about upgrading hoard? What hoard level do you have now in this faction?

hoarding increased by 5 levels, but it still doesn’t work.

Lol…what an amazing and unambiguous task description…

1 Like

Thanks @docdeath for posting on my behalf, me and my brother were stuck on this quest in adventure board for the past few weeks already.

I have tried to raise the following but could not clear the requirements:
Hoard Level (currently 66)
Hoard Quality (currently 10)
Delve level (currently 60)
I’m still missing the 4* troop (Sea Witch) at the moment but other Sea of Sorrow troops are at level 5

I’m at a lost, i could pay 15 gems to skip this but thought i should report this as it could be a bug.

Edit, just opened a bug report:
Ticket number #78545

1 Like

AB doing well I see. *facepalm*

What level (kingdom and power) is Merlantis?

My Merlantis is level 10 and power 2 at the moment.

may be power > 5 level

It seems to consider Sea of Sorrows a regular kingdom, it wants you to upgrade the kingdom level to 5 with gold.

When i click on the arrow, it brings me to the Delve.
No way i can upgrade it like any other surface kingdoms.
I have tried to level hoard level by 1s, 5s but it’s still stuck at 1/5 progression.

I guess kingdoms and factions share the same upgrade entry point, so the arrow works for both. A kingdom will display the level up screen, a faction will display the hoard screen. It just shouldn’t have picked a faction for this task.

It seems like it could be the main Kingdom, Merlantis, power levels instead of Sea of Sorrows.
I’m short on minor traitstones at the moment so i couldn’t test.
If it’s true, then the dev could do everyone a favor and update that misleading description. :slight_smile:

It’s very, very unlikely to be power levels of the connected kingdom. It’s a tutorial task, getting a kingdom to power level 5 isn’t really an early game feat.

1 Like

I notice you have 1/5 on the task.
So something you did advanced the task one step.
Do you play daily delves in Sea of Sorrow?
Try running a delve run on a higher level (the 2x multiplier run), see if it’s that.

Make the category a bug report please. The devs need to be aware of this. @Cyrup


@BelethS I have tried that many times, my 2x multiplier delve is currently 60.

@awryan Yes, i have submitted a bug report, waiting for a reply.

1 Like

One of my members had the same incident and it was confirmed by the devs as a bug.
You’ll have to skip the task and they will refund you the gems.



This was a bug which was fixed quite awhile ago.

How old is the task? Have you had it for a few weeks?
As Fiara said if you send a support ticket I can refund the Gems to skip the task for you :slight_smile:

1 Like

This thread made me realize that skipping a task cost Gems.
I really hat the adventure board even if we don’t have it on Switch yet.