3.2.5 Known Issues (PC/Mobile/Console)


#82

All the effects I think. I can play about 10 matches and I get painful eye aches/headaches. It’s the constant flashing. I get the menus and everything, but every time you guys “improve” the battle screen you make it worse. I do my GW fights, dungeons and daily tasks now and that’s it. If it’s not fixed very soon…like in a day or so then I’m done. That’s not a threat, I just physically cannot keep playing. I know several people are having the same issues.

PS4


#83

Once reaching level 1000 i have stopped being able to increase my gem mastery, i am level 1028 and still no chance to increase gem mastery when i level up.
Anyone have this problem and know how to fix?


#84

This is normal. You get glory and an event key after level 1000, not masteries.


#85

You still get masteries on Ps4 after lvl 1000 though


#86

Sorry if I seemed harsh, Cyrup! I just think that after so many people had complained about the once neon-green button giving them a headache especially when it started to flash yellow after being pressed, you guys should have kind of learned that flashing bright colors are a big no-go.:neutral_face: That doesn’t mean that I think that you guys want anyone to suffer or anything; it just seems like you didn’t learn from previous problems of the same kind.


#88

I ment you get now common and higher troops from the stones.

Btw. What an EPIC pull! :slight_smile:


#89

Either I did not get the correct amount of points for my GW or the GW point system has changed and it is not in the release notes.

I fought my battles today with the correct four unique brown team and I had four unique defenders. I won all of my battles. In the first battle, I did lose two troops, but didn’t lose any troops in the remaining four battles. In fact, with the remaining four battles RNG was actually with me and my team looped like crazy and wiped out the opponants very quickly.

I should have gotten a very good score of over 9000. I only got 7818. Something is wrong.


#90

Check your defense team, as well as your recorded win-loss ratio.

Edit: I don’t read good.


#91

I did that before I posted. My defense team is the correct one and my win/loss ratio is 5/0.


#92

On Android, I am getting quite a few times where I try to enter a PvP battle and the board never loads and counts as an offensive loss. I’m hoping this is just current server load, but my server status is saying everything is good.

So if some of you see people getting a bunch of defensive wins, yep, we may have another cause.


#93

On xbox. Several times, in pvp idk if that matters, i killed all enemy troops and the battle doesn’t end. I had a troop ready to cast so once i cast one or two more times it ended and went to rewards screen.


#94

That’s been around on PC since I started the game (in August). I agree that it seems to have become more common after the UI changed, though. It also happens in explore.


#95

On Xbox. TDS + Umberwolf seems to be causing an issue. Creating a storm every round seems to be preventing the Cast button from appearing for my troops while the storm orb at the bottom is playing its effect. I have to hit B and LB+(Button) again to make the Cast button appear. It’s extremely annoying when trying to play quickly (such as when doing Daily Tasks or soul farming.)

Though, I would speculate that it’s this way for all storm creations and all troops rather than just the TDS + Umberwolf combo.


#96

Fu#@k this s#@t - opened 8 soulforge jewel troops - 3x common, 3x rare, 2x ultra rare…
200 gems well spent :face_with_symbols_over_mouth:

edit: and yes - i think getting commons / rares from those jewels is an issue (havent been informed that they have nerfed em)


#97

On xbox i still got the wrong daily task description (french version)

  • Use at least 3 yellow troop and when i click RB it say use at least 3 green troops (green is the good one)

  • use troop from drifting sand and when i click RB it say use troop from wild plains (drifting sand is the good one)


#98

Xbox english-french translation not done for Tuskar spell decription (come on guys 3 update in a row) and no fix yet


#99

Xbox english-french translation not done in the news section (update infos)


#100

The “Continue” button one gets when getting the rewards for PvP defensive battles is directly over the refresh button on the PvP choose opponent screen. If one accidentally double clicks on the Continue button, one hits the refresh button, losing a gem. One of these two buttons (probably the refresh button) should be moved to one side.


#101


#102

Interesting. Congratulations on your amazing collection of weapons!

@Cyrup, can you please note that on the screenshot above, “X/Y” means “out of Y possible, X are owned”. (In other words, X should never be greater than Y.) On the “Defense” tab of the Guild Wars menu, “X/Y” means “out of X+Y attempts, X successes”. (X and Y are completely independent, and either can be larger than the other while still conforming to math.)This is as inconsistent as the placement of “exit window” buttons, and is sure to be a source of confusion for people.