Zuulgoth not killing orbweaver's repop spider

**Platform, device version and operating system: android

**Screenshot or image: bug zuulgoth 2 - YouTube

What you were expecting to happen, and what actually happened:
I am targetting a spider with Zuulgoth and it fails to kill it.

How often does this happen? When did it begin happening?
The bug happened in pvp. I tried 2 times and it re-happened several times.
Steps to make it happen again
The starting opponent team was Leonis Tower, Hero with Orbweaver class, Arachnean Weaver and Enraged Kurandara.
After killing the tower with skulls and damaging the hero, a spider repopped on 1st slot.
Then, when targetting the spider, it appears that the spider is also immuned to instant kill like the tower before. It looks like the 1st slot kept the immune property to other repop.
I have recorded a video bug zuulgoth 2 - YouTube
I swear, i clicked on the spider when launching Zuul.

Thank you for you fast action on this issue.



This has been happening for long time to me as well as I use a Zuul team for PVP

Yeah. For some strange reason, this combination specifically seems to cause the Giant Spider to inherit the immunity to lethal damage when obviously it should not.

Example of previous report: [REPORTED] Webspinner Superpowered


CaptainBuckles’ findings from that thread seem to be key.

I tried replicating it a few times and couldn’t. Then I saw his comment that you first need to target Leonis Tower with Zuul. After I started doing that, I could consistently reproduce the bug. It’s not limited to Giant Spider either. Seems like any troop summoned to that slot will become immune to lethal damage; I tried a few different summoning methods. Below is a clip with a Water Elemental summoned to the slot with Arboreal Crystal, after the Leonis Tower died to skull damage.


Sunbird works too if it summoned into the slot Leonis Tower was in.


It is the bug where summoned troop inherits the killed troop’s traits, in your case invulnerability of leonis tower

1 Like

This is a big problem in guild wars and the devs could fix it easily.

Dropping the old bug reports that are related to this issue here for the devs when they are back in the office

And I believe this is part of the same issue too

Just seen Stratelier already posted one of the links earlier up in thread. Sorry!