Xbox one servers


#1

Am I the only one unable to play? I’ve been getting an error message for the past 2 hours


#2

Which error and does the game crash upon being loaded?


#3

I can get in game but if I try to look at my guild or pvp I get this error


#4

Ok not the same as what my problem was.


#5

The servers are just crapping themselves. Most evident was the fact I had to retry connecting 8 times for a victory to register.


#6

Xbox One, I’m ok. But I have been reviving a fair amount of error messages. Something like 4,000-5,000 retries per minute. All this week, seems like a server issues. Posted a photo a few days ago.


#7

I got this error all day, now I’m just unable to play. It started after I tried to complete a guild task 2 hours ago


#8

We play too much Gems :stuck_out_tongue:


#9

I’m on PS4. I played 2 hours ago, starting up a new quest(the latest kingdom to be revealed), and had no problems. Then I had to make a store run. Now, just trying to get the game to load up, it crashes. Tried multiple times to start that game, but it always crashes where the progress bar is still filling up.