Game keeps crashing or won't connect to server

What the hell is happening….yesterday I won 4 out 5 Guild War battles but all of them counted as losses!
Today after my first guild war battle the game crashed, so yet another loss or what…

Now my game won’t connect tot he servers anymore, I’m really getting desperate.
Even my guild members start calling me a saboteur.

My invite code: Wicked K - guild: Gem Assasssins

Xbox One

Update: It’s been over an hour now, still can’t connect to server, yet all of my friends are playing the game :frowning:

22 hours later :

I still can’t connect to the game server…

Keep getting the same error message over and over :

Our server are currently experiencing difficulties.Please wait a few minutes and restart the game.

I cannot get past the loading screen, every single time I get this error message :

Must be a problem on your router i been playing all the weekend and no problem here on xbox.

Did you try to reset router? You just need to unplug it 10 sec then plug it again

Does your other game are working? Sometime hard reset on xbox also work.
You just need to hold the power button on your xbox untill it’s restart

Yes, i’ve tried it all, hard reset, router reset, clearing cache, deleting the game…

All of my other games are working fine, thanks anyway!

We should get 3.05 update today, maybe it will fix your problem

X1 has been working flawless this entire weekend. I suggest creating a help ticket.

Hey @Thumbtaxx,

I’ve looked into your account and found an issue. Please check your account and see if you can log in now.

1 Like

I just logged in and everything seems to be working fine now.

THANK YOU SO MUCH!!! :heart_eyes: :grin: :stuck_out_tongue_winking_eye: :kissing_heart:

1 Like