Upgradable weapon doesn't show up on list if you made scrolls from soulforge

Mobile / pc

I made my final dark “purple” scroll to upgrade my doomed chronicle and when i went back to search it using the upgradable search tool it wasn’t available as a weapon to upgrade. Odd. So once I found the weapon it was upgradable but wasn’t shown as such. So I’m reporting it as a bug…

Hope these images help…


I don’t think this is an issue of a problem with crafted doomed scrolls. This is a new way for an existing bug to show up.

Doomed weapons are somehow buggily set to only show they are upgradable if you have N + 1 scrolls available to use, even if you have the exact number. You should still be able to upgrade with the correct amount of scrolls, it just won’t have the icon appear because that has been broken for ages.

1 Like

I could be wrong, but I think it’s actually this:

There have been a few other topics like it pop up over the years.

Basically, UI misinformation caused by lack of server/client communication solved by a restart.


I’ve done the reboot of the game as a simple check just in case it was just a matter of the db refreshing itself. But surprisingly it didn’t resolve itself giving me the green light to report it…

In fact after I reported it, I did a shutdown of my Android and started over and rebooted the game. The weapon and scrolls still didn’t sync up so in this mater it more than that. Unless the degrated server I’ve been seeing all day had something to do with it but when I rebooted this final time there was no warning about it


Gotcha! My bad – maybe it is what @ctenn2ls mentioned, then!

1 Like

No biggie,

I just tried normal things that I have at my disposal first. I appreciate the feedback though…