Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

Filter not working correctly

Platform, device version and operating system
Android, Samsung galaxy j7 prime

Screenshot_20180908-211709

What you were expecting to happen, and what actually happened
_‘I was trying to sort my broken spire troops by level but they didn’t. Sorting them by upgradable worked fine, but trying to sort by level resulted in my troops all over the place. At first I thought it sorted by number of traits instead, until I remembered that I had another epic troop at lv18 that also had 3 traits…which was placed randomly further down the list.’

How often does this happen? When did it begin happening?
I only noticed this issue today.

Steps to make it happen again
I’m not sure. However switching to sort by upgradable then back to trying to sort by level doesn’t change the weird sorting I get for trying to sort broken spire by level. I have not tried to see if it’s also another kingdom.

Note: If you are uncomfortable reporting your bug publicly you can privately message @Cyrup or @Kafka with the completed bug template. Do not abuse this offer to message developers if you are otherwise comfortable posting your thread publicly.

Screenshot_20180908-211655

Thanks for letting us know about this!

Is it happening for any other Kingdom?
Do you still get this issue after force closing and re-opening the app?

No. It’s not happening today. It must have been a one time bug. Thanks!