Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

Something wrong with the game

What you were expecting to happen, and what actually happened?
When I clicked on the Guild tab I was greeting by multiple “Lost connection” error messages and finally an error message saying I’m not in a guild. The game won’t load the pvp screen either. And now after a couple restarts of the game it just hangs at the “Loading Hero” portion of the start up sequence.
What are the steps to make it happen again?
Click the Guild or PVP tab at the bottom of the screen.
Do you have any screenshots or video you want to share with us so we can see the problem? Attach them to your post!

One time it did let me in I got a blank page.

And in the end it just hangs here.

I’m seeing this as well both Mobile and PC.

On the mobile I just got this huge error…(and I still can’t get screen capture to work on it.)

Hey Guys,

We’re aware of the current issues with guilds and server connections. We are looking into it currently.

1 Like

Well after posting this I went and tried to turn the game on and it worked. Even got into my guild page.

How’s that for fast service? :wink:

Thanks @Nimhain and the rest of the devs.

Thanks Nimhain!

Thanks - Sorry for breaking up your Christmas

Btw, thank you for the Holiday Gift.

Frozen on “Logging in” here, on Steam.

Same here stuck in loading screen (xbox)

Had same problem with OP and now I got this error message:

Restarted the game three time already and nothing’s happened.
I’m playing on steam at the moment.

This is also happening on Xbox. Keeps kicking me from the guild. When clicking on the icon.

Closed my steam, then I tried to login on my Android. I got this error message:

When are we moving to the new servers? Or have we already? Because I’m getting much the same as above, and in the past these errors were all indicative of server overload.

Yeah, I also got one error with an incorrect random Username… among a load of other error messages.

It appears to be working again now.
Edited- played one game and it gave the same error messages that the pvp event had ended :frowning:

It has appeared to be working a couple of times (in as far as I was able to log in) the last half hour. Then I click “Guild”, and: No, still not working!

EDIT:
This happens:

  1. I click guild, and get a message “You are not in a guild”. (I am indeed in a guild, btw).
  2. I try again, and the background-picture of the guild-page is loading, but then everything hangs with no data or text loading.

I’m getting a bunch of connection errors. I’ll just try the game later today.

The game is literally unplayable right now.

1 Like

I’m in right now.

Having the same difficulties. Cannot even log into game.

Many years ago as a child I went to church with my family. As it was a Catholic service it always started with the priest saying, “God be with you”, and the entire congregation dutifully responding with, “And also with you”. This one particular morning at the start of the service there was an issue with the sound system and after a few seconds the priest said, “There is something wrong with this mic”.

And the entire congregation dutifully responded with, “And also with you”.

True story! The title of this thread reminded me of it.

11 Likes