Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[Resolved] Fell Roost is not playable

Platform, device version and operating system:
Steam

Screenshot or image:
1


What you were expecting to happen, and what actually happened:
Two guys in my guild have faced with the same issue. They can’t play new Fell Roost faction. Despite the fact that it have the icon of incomplete quest, when the faction screen will be open they see “Quest Complete” message. Althought they didn’t tuch this before.
If try to click on the Quest, there will be a new screen with the “Fight!” button, but it’s not clickable.

How often does this happen? When did it begin happening?
All time for these guys. Restart of the game doesn’t affect anything.

Steps to make it happen again
Open delve.
Click on Fell Roost faction. See that it’s “complete”.
Try to open quests. See the screen with inactive button.

3 Likes

it works on mobile, so it’s probably problem with steam version

It works for me and other guildmates althought many of us also playing via Steam. Probably it’s not 100% reproducible.

Had same issue, #GoWprogrammingskills

Solved it after restarting game twice, and finding the actual Fell Roost faction on the right side of the underworld (the one I was clicking on had appeared in the southern part of the underworld).

The wrong faction showed some variable name when I opened the map through the games menu:

:relaxed: :vulcan_salute:

2 Likes

Btw, Android here.

The right location (or at least the one that worked for me):

:vulcan_salute:

Yeah, it seems like you’re right. My guildmates have the faction icon on the volcano. While I have it as this is shown on your screenshot.

2 Likes

Everything was fine on my end. PC - Windows 10 (x64), Steam client.

Thank you, mine was in the lava as well. Then moved north. I missed the move, thinking it just removed itself from my UW map.

2 Likes

It is getting increasingly hard to spot the new faction location in the crowded Underworld indeed, especially when they move around as in the above instance :sweat_smile: :stuck_out_tongue: :vulcan_salute:

When I first tried it, my icon was down near Sunken Fleet. When I tried to start the battle the game crashed and it was in the correct location once I restarted. Your icon should not be in the volcano…