PS4 Consle Game Crashes After Battles

I keep getting where the game will crash each time I have beaten the enemies in the storyline and I would love for the game not to crash during those times because I do love the game but its been getting rather annoying.

Is there a patch coming for the game soon that fixes that issue or anyone can help me with this issue or least if I may ask?

Also note I am sure there is already a thread about this topic but I figured I’d make one of my own of the issue, I do not have a screen shot at all otherwise I would share mostly because as again its on the ps4 console.

Have you tried to uninstall and reinstall the game to see if that cures it?

I have not but I can try that right now to see if that works since there is still a issue with the ps4 itself where I was able to fix error’s in that option isn’t working because sony has not fixed that problem, but give me a moment to see if that works, will reply with another message

Sounds to me like you have a broke quest or tutorial, and support will have to fix your profile.

Its been actually happening mostly from several kingdoms I have been beating, at some point during game play the game itself will start lagging during a battle, but as soon as the battle is beaten and I get a quest reward that is when the game itself crashes, right now I am in the middle of guild war and so far after uninstall the game and reinstalled it back so far so good, but the lagging and then crash only happens during the story itself during battle and after battle least as far as I know of, but will summit a report on the ticket, thank you.

Welp that is a rip, I tried signing up for the support for the ticket thing and ended up doing so but no email is sent for me to verify it at all, which means I can either wait til they send the email to me for me to verify or be stuck with a bug that will just keep crashing the game which sucks since I love this beautiful game a lot =(

The summit request isn’t working at all each time I try its asking me for a captcha and its not showing, I am guessing its a glitch in the website or something so I cannot do anything at all.

Is there any other route I can take without a glitch happening on website that can help me resolve a crash from the game?

505 games also supports PS4/Xbox version

Good luck, I’ve never heard of the issue you’re having.

Thanks gonna need it and its just weird even it puzzles my friends who also play it too, they at times also have the same issues as I do but not as bad.

@JuriHan87 sorry for the delayed reply over the weekend and sorry this is happening, that would be super frustrating!

As others have suggested please try reinstalling the game but do these things in order:

  • Uninstall the game
  • Delete your Gems of War save data ( you won’t lose your game progress)
  • Turn off the PS4 and unplug the power from the back for 30 seconds, then plug it back in again.
  • Reinstall Gems of War

Also check for any system updates while you’re doing this.

Once everything is up to date and Gems is reinstalled please have a play and let us know if you’re still having the issue.

It’s probably easier to write to us at support from your phone or PC if you want to send a ticket, otherwise I’m happy to check your account for you and get back to you here if the problem persists after you’ve done that troubleshooting.

1 Like