Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[NEED MORE INFO] Since the patch, game flashes make it unplayable

Platform, device version and operating system:
PC, Windows 10.

Screenshot or image:
Insert black square here


What you were expecting to happen, and what actually happened:

Expected to start and play. Instead, I get flashes of black screen. Up to 7 seconds at a time, nothing but black screen.
Yes, the game starts (after 3-4 of these ~7 second black screens). Yes, I can play, if I want to deal with the screen flashing black every time I click something. Check mail? Full screen goes black.
Want to PVP? Full screen goes black.

Sometimes it just flashes some fullscreen game image for less than a second. Most of the time though (maybe 60% of the time), it is just black.

My game isn’t even full-screened. It only occupies the lower right corner, maybe a little more than a quarter of my monitor space, so fullscreen splashes all the time (every 5-10 seconds or so) are very disturbing.


How often does this happen? When did it begin happening?
Since the update.
The update put it into fullscreen mode. I de-activated that, and shrunk the game window back to what it was before, the same way I did last time an update made it fullscreen.
Since then, it’s been flashing.
I tried updating my graphics drivers, it seemed to help that day, but not working today.
I tried setting the resolution close to what I had re-sized it to be - 800x600. No luck.
I can’t play anymore. And I’ve been playing since early 2015. It’s no longer a game, it’s a lifestyle.


Steps to make it happen again
Any one of these causes a flash:
Start the game. (not fullscreen).
Move the window around.
Resize the window.
Change the resolution.
Activating discord / browser / any-other-program window.
Activating game window.
Click PVP button.
Click Mail button.
Start a match.
Collect seals.
Click the World Event button.
Click Fight (menu) in the World Event screen.
Casting some spells in the middle of a match.


Please fix this. Luckily, I’m not epileptic, but it hurts my head to open the game now.

1 Like

Hello Fizziepop, thanks for making this report.

Have you tried uninstalling the game? And could you please let us know more about the device you are playing on?

If anyone else is experiencing this please weigh in.

No, I haven’t tried uninstalling. If I do that, I cannot play at all.

I can see what you’ve highlighted, but more device information would be great. Laptop? Specific laptop? Home made PC?

Uninstalling and doing a fresh install can fix a lot of issues, which is why I recommended it as a first port of call. Support will likely do the same.

Thanks for clarifying. PC as in desktop. Not a laptop. I will give reinstalling a go. Thanks

I did try verifying, through Steam. No problems found. image

Just adding a little more info - the problem seems intermittant.
First day, I couldn’t play until I updated my drivers, then it worked the rest of the day.
Second day, I couldn’t play at all, all day, despite multiple computer restarts at different times of the day.
Today, for now, it’s working fine. No flashing. I didn’t change anything yet.