Lusts third trait doesn't work


#1

Platform, device version and operating system
Android

What you were expecting to happen, and what actually happened
Lust’s third trait says if an ally dies, charm a random enemy. It’s never worked once. I don’t know if it’s because it never works or because she targets an empty space, either way it doesn’t work, and if she targets an empty space, that’s stupid.

How often does this happen? When did it begin happening?
It’s never worked.

Steps to make it happen again
Do you know how to make this happen? Sometimes there are certain steps that can lead to a problem that may not be obvious!
Go into a battle with lust and her third trait unlocked, have an ally die, watch nothing happen. I can try with all enemies and see if that works, if it does then she picks empty spaces too. In which case, kill two enemies, never have her charm anything.

Note: If you are uncomfortable reporting your bug publicly you can privately message @Cyrup or @Kafka with the completed bug template. Do not abuse this offer to message developers if you are otherwise comfortable posting your thread publicly.


#2

I believe that charm only deals damage to the troops above and below the charmed troop. So for example if your enemy only has a troop left in 1st and 3rd spot only, and 3rd enemy get charmed, no damage will be dealt since its no troops above(2nd spot) or below(4th spot).

So with other words, there needs to be troops right next to the charmed troop for it to deal its attack as damage to the below and/or above troops.


#3

Again, does not work. Just tested it on all enemies, it just doesn’t do anything. The enemies are prestine I haven’t touched them since battle start


#4

I see. Looks like a bug then.


#5

Hey thanks for letting us know about this.

This is a known issue which will be fixed in the next update.

Basically what happens is that the Trait will only work if one of your allies dies on the enemy’s turn.

If you have a troop which dies on your turn the Trait won’t trigger.

Sorry for the inconvenience while we wait to get this fix implemented.


#6

Thanks for the response. It definitely happened on their turn though? They killed me with skulls and her skill just never goes off, I’ve never actually utilized any tactics that would kill off my allies on my own turn. I appreciate the explanation though.


#7

Lust’s third trait definitely works with my Firebomb exploding on my turn. On both Android and PC. It’s very easy to see if you set the game speed to 0.25.


#8

@Sorreah Did you kill your first troop or did the opponent kill your first troop?

What troop was killed?
What move did the enemy make when your troop died was it a spell cast or a skull match?


#9

opponent did, I had them do a skull match (I was playing so I set up the skulls for them to easily set it up to knock out my character)
The one to die was my hero, sorry, I didn’t see that question


#10

@Sorreah which Class did you have equipped at the time and what level (NOT Champion level) was the Class?


#11

I can’t remember which but it was either the Oracle Class or the Archer Class (those are the only two I played recently) as for the specific level, also not sure. Archer is level 20 and Oracle is 18, those classes would have been that level at the time I took that screen shot. Its also worth noting I have probably been both these classes while observing lusts trait doesn’t work, I’ve never observed it to work under any circumstance, not just this one scenario.


#12

I’ll make a bug report so we can investigate this more.

If you notice this occurring when another troop dies instead of your hero and the ally died during your opponent’s turn please let us know.