Lost Game, Cant Log In!


#1

I am so frustrated with my inability to even get into the game. I went for 2 days with no Pets And then when I took the advice of the support crew I lost everything that I had. I had the game on both my iPhone and my iPad. After the update, my iPhone refused to link to the current account. I took the advice of the support group and deleted the iPhone app, reinstalled it, and then tried to link it back to the iPad account. The iPhone kept saying That my password was incorrect. So for the next day I played on my iPad which still didn’t have the Pets that everyone else had. After listening to Tavet’s broadcast with people saying they Altrady had 15 and 20 pets, I became frustrated that I still didn’t have any pets, nor have I seen any.

Realizing that I still had not received the update properly, I went to support again and asked what to do. They advise that if it had not updated to delete the game off of my iPad reinstall it and sign in. Well I did all that, and the game will not let me sign in stating my email or password is incorrect. I have not change my password and used it to link my iPhone just a few days before. Now neither my iPhone or my iPad have the game.

I am so frustrated. After a year of playing, VIP 20, never missing a day of sign in, and 1200 plus level…I cant even sign!

I sent support a help request (with screen shots) …no help yet!

What this means to me:

  • bonus losses for not signing in consecutively every day
  • A lot of money toward VIP 20, gone.
  • Two days behind on battles, gathering pets, and collecting bonus rewards that were purchased earlier.
  • Inability to meet Guild requirements, Tasks, guild points, etc
  • unable to collect extra shards from daily dungeon to make gems for next legendary troop. Plus I Always purchase the additional package
  • Frustration of her devoting so much time and money to a game with no !

#2

I am really sorry for what is happening to you.

Maybe you could try hitting the 505 support to get your account back

https://support.505games.com/en/support/home


#3

Thank you. I’ve sent to requests, I will send it again to see if I get an answer. You’re very kind.


#4

What password do you enter?


#5

Because is not the password from your mail. I maid that misstame when i reinstall last night the game.


#6

You have to enter the password that can be found under the account tab under settings in Gems of war main screen.

That password was given to you when you link the game to your device.

Obviously if you would have to had written that password somewhere before, because there is no way you can get it if you can’t get into the game.


#7

I had a photo of the password from the game under the settings tab. I used that password. I had used it just a few days before too link my iPhone. It worked to link my iPhone, but once the new update Occurred it either wiped out my account, or it reset my password. I can’t get in again unless I have a password otherwise I have to start the game all over.


#8

Hi Urfune,

What is the ticket ID of your request? if it starts with 5, It’s with Gems of War support (not 505). Either way, we can quickly help you get your account back.


#9

Here is the ticket number 58948. How can I get it back?


#10

Found it! :slight_smile: I can help you recover your account quickly, but before I do that, can you please try putting in your password again and ensure there’s no space, at the beginning or end?


#11

Ok I will do that now


#12

It still doesn’t work


#13

Weird! I’ll respond to your ticket now. :+1:


#14

Thanks so much


#15

I responded. To be sure you can get into your account you I had to reset your password, and in doing so, you’ll need to verify your email again… anyway… I’ll keep an eye out for your response there.


#16

I responded to the first email. Do I wait or do I go ahead and restart the game?


#17

I will follow up on email.


#18

Oh ok, I’ll look for next steps


#19

I can’t see your email response - please follow the instructions exactly as sent in my last email 3 mins ago :slight_smile:


#20

I clicked the link to verify. What else should I do?