I unlocked the crystal axe never got it

What you were expecting to happen, and what actually happened?
To get the weapon
What are the steps to make it happen again?
There are none its purchased
Do you have any screenshots or video you want to share with us so we can see the problem? Attach them to your post!
I have purchased this item in the invasion event but have not got the weapon

Your filter is empty?
Do you see it when clicking unowned?

I cant see it in unowned either

Same thing here. I purchased Tier III but don’t see the Crystal Axe in either owned or unowned. Very odd.

Actually it’s not odd at all. Happens all the time with these devs.

Hmm glad to know im not alone haha

So is there a fix spent the gems want the rewards

Have you tried restarting and checking again? Sometimes it can take a little while to appear.

Yes ive done that at least 5 times i got it last night still not there i will wait a little longer

1 Like

Do you have any screenshots, as well, of the Tiers you purchased and where it’s supposed to be? But yes, don’t worry, this thing has happened before, so if it doesn’t show up at some point, Support should be able to help you out.

Hey there, can you please be sure you have properlly force quit the game and reopened it. I can see the Weapon was logged as received when you purchased it 19 hours ago. It looks like you were online over daily reset, and purchased the Weapon without restarting the game after 7 am GMT.

To force quit:

  1. Start by pressing the Xbox button to open the guide.
  2. Verify that the game or app you wish to close is highlighted from the mini-guide on the left side of the screen, and then press the Menu button on your controller.
  3. Select Quit

Xbox likes to keep games running in the background. Over daily reset, our server data changes over, and if you don’t immediately earn something you bought restarting the game will fix this. We also have an article on not receiving weapons immediately after purchase here.

1 Like

Thank you that totally worked :grin: