Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

(Resolved) Purchased Skeleton key weapon, not showing up in inventory

Please check the known issues list before posting a bug.

Note: If you are uncomfortable reporting your bug publicly you can privately message @Cyrup or @Kafka with the completed bug template.

Platform, device version and operating system:

Screenshot or image:

What you were expecting to happen, and what actually happened:
This is simply what you were trying to do and what happened instead. Example:
‘I was trying to start an Arena battle, but Gems of War loaded Broken Spire quest instead!’

How often does this happen? When did it begin happening?
Was this a once-off bug or has it been a consistent issue? Does it only happen after doing a particular game mode?

Steps to make it happen again
Sometimes there are certain steps that can lead to a problem that may not be obvious!
Example: I lose once in the Arena.
I then exit to the world map.
I then tap on Broken Spire on the map and then tap Arena.
Broken Spire’s quest loads instead of the Arena

1 Like

Same for me on Xbox. :slightly_frowning_face:

1 Like

Same on PS4 :-1:

Yup, SOP. Weapon issues on new class. Template being used when new weapon comes out has not been fixed and is continued to be applied.

1 Like

This is normal. So normal someone made the thread yesterday as a joke. The devs are too busy adding new features to sell you traitstones to work on this. They’ll apologize and you’ll get the weapon tomorrow.

It’s shameful and unprofessional. But it makes for a pretty good review in the app stores. Well, good in the “fun to write” sense.

7 Likes

Same here on mobile and PC

1 Like

I have lost my sass crown to you. All hail the new leader of the sass.

Same on PC (Windows 10).

  1. Unlocked Thief class with Brian the Lucky
  2. Changed Hero class to Thief
  3. Leveled Thief class to 20
  4. Used a Major Orb of Ascension (“Class weapon received!”)
  5. Used a Major Orb of Wisdom
  6. Escaped out to overland map view
  7. Opened mail to successfully acquire Skeleton Key
  8. Opened Events > New Hero Class > To Battle > Fight > pick King Mikhail > begin building team > choose Weapon > Skeleton Key doesn’t exist at all

I have been looking forward to a Goblin Hero class for so long now and I can’t even play with its class weapon that I rightfully earned! And now I can’t even change my Hero class back to Sorcerer because I don’t have 50 gems. My enthusiasm for spending the day GoW-ing has been ruined. :frowning:

3 Likes

iOS, PC here. tried on tablet, phone, and PC. No luck. I splurged and actually used real cash to purchase gems, used gems to purchase troops, sigils, traitstones, and the Skeleton Key weapon. Got the sigils, and was able to level up the class category, not sure if I got the class XP but assume I did because I was able to level up. BUT… I Did NOT get the traitstones (should be 10 Arcane Skulls - I have zero. I assume I also didnt get the runics, majors and minors either because of this but can’t be sure on those.) we Were supposed to get 30 troops as well. I’m pretty sure I didn’t get those either because I still have only 1 troop of many of the ‘good’ (Fizzbang, Grapplepot, NoBend Bros etc) goblins :-)) Support seems remarkably silent on this, I sure hope it’s fixed soon and they can fix it for all of us who are having issues!

1 Like

In the past, they have offered zero support on weekends, and apparently have no one on call (still blows my mind).

I would anticipate this broken until Monday.

1 Like

They’re approximately 13 hours behind england. reset is 7am (british time cause daylight saving) that works out at 6pm in australia… Hardly “the weekend”.
And besides, somebody rightfully put a bug report before skeleton key was even released, During which time, they were in the office.

Same here, just purchased with gems and no skeleton key in my inventory…

Actually they are 11 hours ahead of england. Reset was at 6pm friday their time

3 Likes

Even if you go old school and win 250 times with the class… Still no weapon in your inventory. Must be a “legacy code” issue.
Screenshot_20181102-195649

3 Likes

I really do think these are bad outcomes.

Same here on xbox one just purchased with gems to get the weapon and it’s not in my inventory. I even leveled up and still no skeleton key. Dumb.

Why are trivial issues like Dragon Eye fixed quickly even though it really was not a problem. This issue you spend like 1000 gems on a weapon you cannot use…Can someone figure out how to fix this issue because it happens every single time…good grief…Maybe I wanted to use the weapon after I bought it…Did anyone think that maybe after a purchase that someone might want to use the thing they bought before they go back to work on Monday…If this was the first time this happened I would cut some slack but this is like every single weapon lately…….No i’m not looking for compensation. I’m wanting the ongoing issues that bug the crap out of everyone fixed like the troop screen that still freezes and the weapon that does not show up til event is over. Maybe I’m just expecting too much.

Same for me. I bougth the weapon and it’s not in my inventory.
Devs please do somethink.

Same - should have read the forum first - now I’m stuck with a thief class without the paid for gems hero until the bug is fixed.

I did same. Switched to thief class to level it up to use new weapon but since we don’t have the new weapon after purchasing it we have to switch back to another class. That’s 100 gems. Might not seem like much but hey, it’s 100 gems we spent on top of what we spent to get the weapon.

1 Like