(Resolved) Purchased Skeleton key weapon, not showing up in inventory

The weapon should be in your inventory now

1 Like

Just confirming, the fix should be out now on all platforms.
If it doesn’t show up for you, you may need to play an extra battle & then return to the Weapons menu (or restart the game)


It is on iOS. Thanks.

Not seeing it on Xbox still, and a few others I talk to haven’t seen it as well.

Same here. Still not showing up on xbox

Not on Xbox after restarting

1 Like

@Sirrian @Saltypatra
Seems this is not the case on xbox yet?

unowned owned%20weapons

Not on Xbox One… After 24+ hours I still don’t have it. I’ve restarted, used reset/power off, still not there.

My only day off! Gotta be up at 2am for work so I’m hoping this fixed before I go to bed. Kinda excited to use this with the thief class

[PC] I have the Skeleton Key in my Weapons panel now.

I’m still disappointed because I had all of yesterday to play, but today I don’t have that much time to play with the new class. :frowning:

No weapon on Xbox

Yup just signed in on xbox and did a few battles and still no weapon

These on going blunders, allowing 1000s of people to use Dragon Eye to breeze through every faction then nerfing it before the average player gets the same opportunity… I’ve been playing Gems and PQ since they first came out and I’m about ready to quit. The event is more than half over and I can’t even use the weapon that I paid gems for…

Still no weapon today after doing battles and doing the usual. :frowning:

Yes of course having an easy path for players needs to be nerfed to ensure a potential revenue stream.
However, after trying the brand new Mytic for kicks THAT 3x chance to convert troops is motivation behind the nerf. No way they could have that guy used in Delves converting the entire team to worthless troops.

Called it. Sort of.

Hey guys, thanks for the update. I’m sorry the fix is not appearing on Xbox :frowning_face: I’ll let the team know

@Strat @AlphaNate @WickedCoolHand Please stay on topic. Derailing a topic is against the guidelines. You’re welcome to suggest feedback but this is not the appropriate place.


Hi all, the fix should now be out on Xbox

If you don’t see it after force quitting and restarting Gems of War please restart your Xbox :slight_smile:


Hello Cyrup, I can verify that XBox still does not have the key available.

Mine has showed up on x1