Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

Guild Invites on PC version

PC version/Steam
Guild Invites
You click on a Guild Invite
You click yes that you want to join
The game gives you the error message: by invitation only.

Invite code: jbfranklin26

1 Like

Have this issue all the time.
And that’s when I’m able to actually send an invite on steam. Most of the time legit invite codes show up as not working.
To help the report though you should delete all the stuff that isn’t relevant to your issue.

Hey Presto,

This is an issue we’re currently investigating.

Could you please provide a little more information? ie:

Did you exit the game between leaving your old guild and trying to accept the new invitation?
What were you doing before you tried to accept the invitation?
Is it possible the Guild you were invited to reached the maximum members before you accepted the invitation?
Probably irrelevant but what position were you in your old guilds guild wars? (ie. Paragon, Soldier, Herald etc)

On the inviter side.
I could invite him as the Recruiter with Fear the RNG as guild.
But could not invite him as …X… in Gems N Roses.

Seems to be only an issue on steam. I never have an issue on mobile.
Sometimes if I restart the game, then I’m able to use the invite code. Never had an issue with invite codes prior to 3.3.
Was hoping 3.4 would fix it.
Seems to be an issue with invite codes in general since …X… never works for anyone as an invite code.
I figured by now that y’all were aware of it so never made a report myself about it.

I left my old guild for a while and left the game for an hour. When I returned to the game, I had 2 invites and tried to accept both.

@awryan sorry for the super delayed reply, I need to get on the forum more often.

This is a known issue we’re investigating. We’ve found that it helps if the person who invited you is online when you accept the invite so if you have the problem again please try that if it’s possible.

Sorry for the inconvenience.