Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

Guild member can’t join

What you were expecting to happen, and what actually happened?
I expected that when I sent multiple invites to join my guild, the invitee would be able to join from at least one of them. I further expected that the support desk would be able to offer support to get this individual into my guild. Based on the fact that I am posting here, you can guess that neither one of these things happened.

Do you have any screenshots or video you want to share with us so we can see the problem? Attach them to your post!
image
image

The guild in question is Gem Boiz. The invite code that seems cursed is trampus_hek2. We’ve been trying to get this person on board since Saturday. They’ve already missed the burst of guild tasks associated with the weekly rollover, and they are likely to miss out on guild wars this week now also.

Edit: this is not a rare occurrence with our guild. I think more than half of the people we’ve tried to invite have required multiple attempts. They get an error saying that the guild is invite-only, which pops up from the invitation to join the guild :upside_down_face:. I would like to believe we aren’t inviting morons, so the conclusion I draw is that there is a problem with the backend or the instructions for new players aren’t obvious enough.

I’ve had that happen the last few times inviting folks to ours. Even worse it thinks the person doesn’t exist or the guild doesn’t exist.

don’t know why but I just keep trying and the other person does - and finally it works.

Well I guess I should avoid doing a new post since I have the same problem, so I’ll do it here. The guild I’d like to join is Guardians of Terra, my invite code is Meksil

image

Invite Pending as you can see here
image

You can also check this topic if you want proof that the poster invited me 10 hours ago
https://community.gemsofwar.com/t/29-30-looking-for-one-new-member-guardians-of-terra-rank-132-hardcore-or-casual-come-join-our-active-friendly-and-generous-bunch/23784/136

Taisiakat’s solution might work, but since Elarcadia (the person who tried to recruit me) and I aren’t from the same time zone, that won’t be an option

Have you tried taking invite only off your guild then having them find your guild from the search feature and join you that way?

I haven’t, and I’m loathe to try that without being in real-time communication with the person. Don’t want the riff-raff sneaking their way into our walled paradise! (It’s a neat suggestion, though. Might work for other cases.)

1 Like

Kick any riff raff that enters while waiting.

Since 3.3 I’ve had issues with invite codes and guild invites. I have a whole slew of work around for Bugs of War.

Second invitation worked for me. It was still annoying due to different time zones

Turn off invite only then invite them again and they should be able to get in.