Giant spider gives turn to enemy

What you were expecting to happen, and what actually happened?
have board with similar setup. p-purple, g-green.
§§(g)§§
Cast giant spider spell by choosing green gem
game freezes for a sec.
gems are transformed, but didn’t get mana (I think) or extra turn (100% sure)
enemy gets purple mana (I think) and turn (100% sure)
spider swarm is summoned

What are the steps to make it happen again?

transform gems to other color when there is 100% chance to get extra turn.
first slot should be empty. So giant spider can summon Spider swarm

Do you have any screenshots or video you want to share with us so we can see the problem? Attach them to your post!

no.

P.S. happens very very rare
P.S.S. Unit is not frozen

1 Like

Was one of your purple units frozen? That would explain the turn.

2 Likes

hmm. not sure about that.
if I get problem again I will double check

got same error again. casted giant spider. summoned small spider, but I didn’t got any mana.
don’t know about enemy because bot foxes had full mana
fought againts 2xspirit fox.
btw. spirit fox drained pharos-ra for 14 mana.
since when he drains 14 mana? he drains 7 mana + dmg boosted by yellow gems removed

got that error again.
fought against 4x marid. they didn’t cast any spells. so I didn’t have any status effect.
but dragon soul in first slot was dead from skull attacks.

I casted giant spider.
game froze for a second.
I didn’t got mana.
Spider spawn spawned in first slot.
enemy got turn

problem occurs only when there is free first slot. (not sure about other slots)
but when there is no open slots, I didn’t getting this bug

Several months ago, I experienced this same issue with the creation of Spider Swarm when cast by Giant Spider. The extra turn from the match-4s would pass to the AI instead of me. Occasionally, the Spider Swarm would even spawn in the top slot of the Opponent’s side instead of my side.

I assumed that these odd effects may be due to the 3rd trait of the topmost AI troop remaining active even after that troop’s death. For some reason the spawning of Spider Swarm seems to cause this issue, specifically.

got same bug again.
fighting againts
Dragontaur/Dragon Soul/Venbarak/Dimetrexia.

Same scenario.
first slot is empty. casted giant spider.
summoned spider swarm. enemy got turn.
can’t confirm who got mana
because pharos-ra had full mana

more info.
got that bug again.

fought againts knight coronet/dragon fire/druid.

first slot was empty. casted spell.
after spell board looked similar to this
x-some color
p-purple

xppp
pppp
pxpp

spider swar was summoned didn’t got mana or extra turn, when we clearly can see that I should get it there.
and then enemy made turn on purple gems (changed middle purple gems that in theory should achieve nothing, because nothing on board changes. s and then got purple mana and extra turn.

Are you on console or PC?

I play on the pc

I play on PC too and in the 1000 times I have used Giant Spider I have never had that happen.

Nobody have got this error before, I have never seen it on the boards or heard about it btw. So surely this must be something unique adressed to your account. I would send in a ticket if I were you. https://gemsofwar.zendesk.com/hc/en-us

2 Likes

still getting this bug when there is lots of gems to tranfsorm.
I transformed blue to purple.
Spider swarm is summoned and you can see that there is some gems that should be destroyed.
But now it’s enemy turn and he’s changing purple and grey gems.

3 Likes

Can confirm this bug happening on mobile also. Casted Spider Swarm into match-4 but the gems didn’t disappear, giving the turn to the AI who in turn just swapped two purple gems within a match-4 to collect the mana. Totally explains the multiple times that I thought I was just having a brain fart and misclicking after losing the turn when I was expecting to get an extra turn.

1 Like

still not fixed…

Did you send in a ticket like Eika suggested?

damn. I forgot I did that