Defend Kingdom not working as it should?


#1

What you were expecting to happen, and what actually happened?
Each time I go to the PvP section , it shows my previous home team as my defence team. I changed it a few times to another team with another Kingdom as my home kingdom. But, alas, when I go back to defense, it still shows my old troop setup and banner.
What are the steps to make it happen again?
Above
Do you have any screenshots or video you want to share with us so we can see the problem? Attach them to your post!
Nope


#2

It’s probably what I noticed too just now. I changed the first two teams in the troops section; new troops, banner and changed the names. After that I went to take revenge on an invader with my newly setup teams, and lo and behold, it was all changed back to before: Team #1 and Team #2 with the troops as before I changed it.
This was on Steam.
Then I took my iPad, changed the teams again and everything was working fine there. Went back to Steam and the teams were reverted back again. And also on the iPad… Strange that no one else has reported this. Everyone else having no problems on Steam?


#3

So “glad” I’m not the only one. Thought it might be one of my stupid mistakes again :stuck_out_tongue:


#4

I had a similar experience. I created a team in slot 2 and renamed it. When I went to invade the new team was not there and it was named back to Team #2 with the previous setup under that banner. I had a space in the name of the team, so I thought maybe that caused a problem. I re-created the team with a new name with no space and it stuck. I also purposefully closed the exploded team view by clicking on the team banner again before leaving the screen. I am on an iPad Air 2.

EDIT
I did not use the attack interface troop creation screen for either the initial or secondary creation. I went back to troop creation to re-create the team. I did however ensure that I went back to the troop button and closed the banner before leaving the screen. Seeing some other team names, I am less convinced my space in the name was the problem. I am betting it is a sequence of clicks not “saving” the team as desired.

-Razlath


#5

Same here. Team changes made in troops are not saved and brought over to pvp or defend.


#6

Same here. In order to save changes to teams, you have to do it from the screen that pops up when attacking someone. Kind of annoying, I think it’s a bug.


#7

I just ran a bunch of tests to see if I can reproduce why it worked for me the second time.

My first team failed to save. I assigned weapon, assigned troops, and then changed name. I left the filter I had in place and closed the banner using the little X next to it to collapse the troops.

Every subsequent team has saved successfully. I have repeated the exact steps above as well as various combinations of filter / no filter, open / closed banner detail, and tab left selected across the top.

Perhaps it is something with the first save per session not sticking, but the rest working? Not entirely certain, but hopefully that helps the troubleshooting team.

-Razlath