Console 2.2 Known Issues


‘Rowanne is definitely broken. She’s not even wiping a team of mechs on normal difficulty with 45 armour!’

Hey dan remember posting that after the update?



Chat service is certainly annoying since checking chat when it’s down freezes the game.


OK, yes that’s an issue,but you’re saying the game is broken. I just don’t use rowanne!


I saw this bug couple time and finaly could make a video, i think it is only animation bug
When kraken make his cast and then make a 4x gems match, sometime we see him doing another hit 3 damage to everyone but usually we dont see him hit, we just see the opponent health drop -3


Unintended but not bad XD Might be worth doing all the time.

The errors on battle completion people are seeing, are they the token mismatch errors, or the battle has already finished errors, or something else? Just want to confirm what people are seeing.

We’re looking into chat becoming stable once again, and also fixing the fact that when its down and you check chat the game crashes.

@Frozensilent: The new offers should be available for purchase now.


About battles errors: I have the 6 circles loading indefinately before begining battle that force me to exit game and reload. A loss is counted. Also the “kingdom doesnt match” msg after a battle, with this one, no loss counted but no win too…like the match never happened.


I’m getting the “this battle has already finished” error. Sometimes it counts as a loss and sometimes no result. Ps4. I got it twice yesterday but not at all today.


New week, new events, same bugs! Only 36 battles to wait for the 1st infinite 6 circles turning with the error message about servers…I tried “retry” 15 to 20 times for no result…forced to leave game and a loss is counted.
If there is still a player trying to stay at zero pvp loss, my advice: Just stop! Forget it!


For kicks I tried a full yellow Mana team in PvP Invade (this weeks Bonus Gold Event). Does anyone know if you get the +400 Gold if one of your troops is a Yellow Hero (Priest)? I won, and am uncertain if it was awarded:)

I see above there is an issue with Hero counting as “Type”, but what about Mana color?

Just curious as Yellow is too slow to actually use. I can’t ever recall a time where the Hero was working 100% as intended. There is always something not quite right with that “Troop”.


With the filters on the troop selection screen was trying to sort by type and was pressing right but nothing was working, sort by level worked though.
Also with troops, was trying to ascend some troops but it was stuck on the level screen and it was frozen, only button that worked was the pause button.
I signed out, signed in at the menu screen and both problems keep coming up.
This is on Xbox One.


Still see this screen when trying to go in chat


Chat should be up again. We are working on a fix for this.


No luck for me, fully restarted game and same window appear when i tried to go in chat


As mentioned in another thread, there seems to be a significant lag quite often when accomplishing a battle victory on Xbox One. Can occur on Explore, Quest, or PvP. Can lag for a good minute or longer while waiting for Traitstone to appear, which would seem to be the time that the game is accessing the server to record the victory (speculation on my part, admittedly).


Not a major deal but please add in game lag when using abilities to the list. This can also occur from the AI using abilities on the player.

Whenever an ability is cast for the first time in a gaming session there is 5-8ish second delay while waiting for the animation to display. For some reason this does not occur with every casted ability, and the second time its fine. I will make a note which ones I specifically see it on.


I found a few issues with the new “Offers” section that I would consider bugs.

  1. For the first offer, “Starter Pack”, it comes with some armor. There’s no indication what this armor actually is. The name of the armor is not there and when you put your cursor over it there is no prompt to hit the X button to see a preview of it on your troop like there is for the weapon in starter pack 2. Someone familiar with the game may be able to link the picture to the most likely armor, but new players will certainly not know what they are getting. I can’t imagine you guys are selling too many of these packs with people not knowing the armor they are purchasing.

  2. Once you scroll down to the “Path to Glory” offers, at the bottom of the screen are two lines explaining what asterisks mean. While there is a " ** " next to the mythic troop, there is no " * " anywhere on the screen. This amounts to you guys explaining what an asterisk means that isn’t anywhere on the screen. Was as asterisk meant to be included next to “Daily traitstones” at the top? If you guys intended for there not to be an initial asterisk, then the line below shouldn’t have an asterisk at all and should just be a statement, and the “Mythic troops **” should be changed to just 1 asterisk.

  3. “Growth Pack II” again has two sections explaining what the asterisks mean, this time with zero asterisks anywhere on the screen for us to presumably reference. It looks like a single asterisk should be after the line “Rewards will unlock at level 50, 75, 100, 125, and 150!” and the double asterisk should be after “Mythic”. The same applies to Growth Pack I and Path to Glory I. I will also note that the format of the mythic troop is different from the earlier sections - I think all offers should be consistent in how they present rewards like this. For Growth Pack II it only says “Mythic”, the other ones say “Mythic Troop.”


Nice write extensive up! I noticed all those the first day but forgot to post. I guess its time the change my “Green S” and ask for a sub title… nah.


Serious good points


For reference this is what the screens look like on PC and where the asterisks should probably go:


With this, are you finding it’s happening consistently? Or was it a once off occurrence?


It was just a once off, did not happen the next time I went on.