Cannot exit guild admin screen

6th Gen iPad. OS version 12.3.1. Game version

What you were expecting to happen, and what actually happened:
I went to the guild admin screen to change the announcement, and I cannot seem to exit. I believe there used to be a back arrow or something to get to the main guild screen. I had to restart the game to get out of it, and it didn’t save the new announcement. I am a Sentinel in my guild, so I have the proper permissions.

How often does this happen? When did it begin happening?
It just started today. I did the latest update yesterday, and this is the first time I’ve tried to access the admin screen since then.

Steps to make it happen again
I clicked on Guild at the bottom of the screen, the main guild screen opened, I clicked on Guild Admin, entered a new announcement, and then realized there wasn’t any way to exit that screen.

I asked the guild master to try it, but haven’t hear back from her yet.

FYI, I just tried it on my iPhone and I see the back arrow. Weird.

Same thing happened to me on steam, no back arrow. I tried android and it would work ok.

It’s a known issue that’s been stated as unfixable until 4.5. So don’t try to admin your guild for like, the next 4 months.