Can not open event chests


#1

I’m trying to open a bundle of 50 event chests, and it fails every time, with a “Retry” button. No matter how many times I click Retry, it never succeeds, and since there’s no back option, I’m forced to close the game.

This happened multiple times, both on my PC and Android phone, and with 2 different internet connection. Any other action in the game works just fine, including opening other types of keys, so it’s not a simple connection issue.

Can anyone help, please?


#2

Does it let you open one event key by itself?


#3

One event key works, most of the time.

The 10 pack worked fine on the first try, the second time it worked after a retry, the third time it did not work at all, even with multiple retries.

The 50 pack I did not see working even once today, no matter how many times I tried and retried.

EDIT:
I have tested:
50 gold chests, using keys and using gold;
50 glory chests, using keys (I have no plan to waste glory on tests)
50 gem chests, using gems (I have no keys)

They all work without problem, only event chests don’t work.


#4

50 Event Keys do not work for me either. Constant error and having to restart game.

1 and 10 Event Keys work just fine.


#5

Hmph… Not sure then. That is strange. Hopefully a dev can explain what may be going on here. I bought a 50 event key pack last week and it worked fine. I have no desire for it this week (nor do I have the gems), so I can’t try it out, but can attest that it was working as intended when Blighted Lands was the event kingdom (well, for me at least).


#6

If I had to guess, I’d say there’s a bugged item in the award list of event chests this week, which causes this to happen when it’s supposed to be awarded. The drop chance of that item is high enough to almost always be awarded in a 50 pack, but only occasionally on a 10 pack, and in a single chest it would be uncommon enough to not be perceived a problem, which explain what I’m experiencing.


#7

Or this is one of those mechanisms left in Parse’s plate


#8

I lean towards my theory as I was able to buy 10 event chests after hitting retry of server come tom and now am completely unable to buy them again.


#9

“You are about to purchase 10 Event Keys - are you certain?”
“Your connection to the server has timed out. Please try again later”
“Your connection to the server has timed out. Please try again later”
“Your connection to the server has timed out. Please try again later”
“Your connection to the server has timed out. Please try again later”
“Your connection to the server has timed out. Please try again later”
“Your connection to the server has timed out. Please try again later”
“Your connection to the server has timed out. Please try again later”
“Request timed out”

… No, not sure.


#10

Doesnt even work for 1 chest now :confused:


#11

Check your game’s cache on pc. Open steam library>right click on gems of war in your list>then choose from that menu that pops up properties>then click on the local files tab> then click on verify integrity of game cache. It should validate and if anything is wrong with the files it will fix the issue. That is all assuming you are playing the pc version.


#12

As I clearly said in my first post, it happens on both PC and Android. It also happened to multiple different people, so it’s more likely to be a server-side issue. I tried your suggestion anyway, and as expected it doesn’t help.

There also haven’t been anyone yet who said it works for them. Does it work for you? Or did you suggest that the problem is on my side without even testing it yourself?


#13

I am playing on iPad Air 2 (ios)


#14

I’m I managed to get 3 10-key event packs 13 hours ago and no go for the forth


#15

It works for me and i did not get the problem after my first bout with it. Basicly this happened to me on pc some time ago and the devs could not fix it i tried every self fix except the one explained and after finding out i had corrupted files even after i reinstalled the game i checked the cache and found the broken files and replaced them and that fixed my issue. I know it has fixed some other people’s issues too but it did not work for you so the issue is not the cache of your steam so it can’t possible be a broken cache on your phone either. reinstalling did nothing so we can confirm that for you it is not a memory issue, program issue or ram issue. Checking the cache was for ram well sort of.


#16

Hey guys,

The server-request to open 50 event keys is running very slowly and timing out then losing connection occasionally.
I spent yesterday evening investigating, and found some code that could be written more efficiently (nested loops for any programmer-y types out there who are interested).
I’ll be deploying that to the server shortly, and we can see if it fixes the problem.


#17

I was having issues with 10 keys as well.


#18

It was all running through the same piece of code… potentially 10 keys could have had the same problem (if that’s what the problem was).

The new code has now been hotfixed to the server. Let us know if you have any more problems.


#19

I just successfully opened a single pack of 50 event keys. Didn’t try any more, but I believe it’s indeed fixed.

Thanks @Sirrian!


#20

Same here for 10 on ios - fixed. Thanks !