Bug: Dragon summons not working

I’ve tried casting Krystenax and Dragon Egg’s spells, but neither of them triggers the summon part of their spell.
Tried a team of 1 Dragon Egg. And a team of 2 Krystenax. Neither summons anything.

1 Like

Known bug. Summons don’t work if you don’t start with a full team.

1 Like

Thanks Jainus. Didn’t realise that.

Fix is apparently due in a future patch, hopefully soon… and until fix is made, I really think they shouldn’t do these summon-for-snots events.


With demons summoning it was do-able.

With dragon, i don’t really see how we can reach the goals. I mean with keeping a lil’ amount of fun. I think i will skip totally this one …

Very annoying: the bug doesn’t apply to the AI team, only the player. Just played a single Nax team enemy; it was able to summon (twice) Drakons just fine.

Guess I’ll just have to get out the old Black Beast again…

mix of sacrifice, baby egg (best for summoning) and whatever other 2 you can think of to speed up the team. Prismatic orb is one example, fortress gate (to block dmg without doing much to make the fight last as long as possible)

Another (related?) bug. Celestasia’s third trait (get barrier on 4 match) isn’t working when she is summoned during battle…