Black manacles still not working

#1

Please check the known issues list before posting a bug.

Platform, device version and operating system:

Screenshot or image:

What you were expecting to happen, and what actually happened:
REPLACE THIS TEXT WITH YOUR ISSUE. e.g. This is simply what you were trying to do and what happened instead. ‘I was trying to start an Arena battle, but Gems of War loaded Broken Spire quest instead!’

How often does this happen? When did it begin happening?
Worked 3 times in the last 94 casts. I’ll stop posting it when someone gets off their asses and fixes it. Still working at less than 8% over the past 4 weeks.

Steps to make it happen again
REPLACE THIS TEXT WITH YOUR ISSUE. e.g. Sometimes there are certain steps that can lead to a problem that may not be obvious!Example: I lose once in the Arena, I then exit to the world map, select broken Spire on the Map and enter Arena. broken spire’s quest lost instead.

#2

Let me see, in a pvp fight AI eaten 2 of my troop in a row, from my pow it work even too well.

Sure we can make that work also for us like that so at same time we get a new unwinnable def for GW seen ai then gonna eat TWO troops at once each cast.

#3

I know the feeling, but my megavores kill at 30% rate on 4-5 skull matches. I have seen gemdrop changes too, makes too many “magic matches” all of a sudden. Like three days ago. Seems like two programmers fighting the others “perfect code”. I wouldn’t mind dropping the pretense of random. doesn’t exist anyway. Chaos…

#4

@aartemis please fill out the bug report form you posted so I can know what the issue is.

Black Manacles appears to be working so if it’s not you’ll need to actually tell me what’s wrong.

#5

As far as I can figure, the odds of this happening are low, but not shockingly low.