What is going on with the server?

What you were expecting to happen, and what actually happened?
Tried to open 14 chests.

Alt+F4’d the game and restarted.

Restarted the game with repeat of above pic.
What are the steps to make it happen again?
Don’t know
Do you have any screenshots or video you want to share with us so we can see the problem? Attach them to your post!

Same here, guess the servers are having problems?

I’m assuming this is PC? I’m not seeing any issues on mobile.

I went back in and had the same issue when trying to open chests. I went into the guild chat and when I came out the chests were able to be opened. Then went into the guild to complete some tasks and

Nasty week for me I guess. The game hates me cuz I get so angry watching the ai get 8 matches to my one. I guess.

@Studs yes I’m trying to play on pc.

The task I was trying to complete did not complete. The game did not deduct any gold from my coffers. But the task disappeared from the list when I went back in.

Same thing right now on mobile. I’m getting it pretty much non-stop even on login. Various errors, each different.

Too many people screaming at their screens. Maybe? I can hope others are as frustrated this week as I am. These glitches don’t make it any better. We’ll see what the devs say. They’ll know what’s up.

We’re encountering the same error here… investigating right now

Could be more server issues due to the dying provider Gems is using. Have to assume the quality/service has deteriorated as the servers close up shop.

Same here … just started playing and game crashes with erroors

Here’s another one @Sirrian if it helps.

Initial Findings: ONCE AGAIN, our server-provider Parse is misbehaving… it’s nothing specific to Gems of War, and is affecting a number of different apps. These 3 errors (incorrect login, success/error, & temporary error) are all caused by the exact same issue

Along with the other affected apps, we’re all currently yelling at Parse to fix it! Sorry for the inconvenience everyone.

We’ll be migrating to new servers as soon as possible… it takes a little while to coordinate a server-move, and quite a bit of testing, so bear with us over the next few weeks as we move towards it.


FYI this is happening on Xbox as well.

1 Like

I’m no computer geek so I can’t imagine what would be invovled in a move like that with a game of this depth. Thanks for the information @Sirrian.

Was about to post myself. Got one of these ‘temporary error’ thingies… and clicking it made it go away. Then it freaked out a bit more, didn’t open my chests. I tried again, got another one that wouldn’t go away.

Trophies aren’t registered. Just played a few battles and got those errors aswell. This is really frustrating…

Frustrating yes, but logging in to this forum and seeing others are having the same problem is actually reassuring.

Prompt, informative updates from the devs, that’s really exceptional. Thank you!


Just to add it’s affecting the ps4 too.

Stupidly, I failed getting the reward for a treasure map, and so what did I do? started another treasure map, which also failed to provide rewards.

What have I done with my life.

I appreciate that you’re about to be a little bit busy. (I have done a server move, and mine was local, so that made it easier!)
It’s good to see you treating this as a priority. Faith currently being reinstalled.

Don’t forget that rewards are promised due to the inconvenience.