Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

Titans Bane weapon not working correct

Platform, device version and operating system:
Windows 10

Screenshot or image:
nope

What you were expecting to happen, and what actually happened:
When activating Titans Bane it creates a Doom skull. Even if this doom skull appears connected to two other skulls it does not make an give a skull attack. instead a bit later it explodes taking one of ordinary skulls along. That is by the way weapon upgrade 7 and 9. So you should make it work as a skull attack when you create an extra doom skull so there is 3 in a row. At the same time it would also be great to push the timer for these events as it is reaaaaaally slow :slight_smile: What I mean is it took several seconds for it to create the doom skull and then explode the doom skull. There is really “artistic” moment to enjoy the event that could be paced a bit faster :slight_smile:

How often does this happen? When did it begin happening?
I experienced it a few times in todays class trial. And it did happen in several fights

Steps to make it happen again
No other things come to mind than it must be a general problem. I was in and out a few times from class trial and I think it happened in several re-attending class trial

This sounds like an order of operations type thing. I don’t use that weapon but looking at it, it does several things. My guess would be that all of these things are executed in a certain order and that might be why you are not getting the result you expect.

I could be wrong here. But that would be my first guess.

This appears to be intentional, the weapon affixes are considered part of the spell. Whenever you cast the spell its effect and affixes all get applied in sequence, only afterwards the board state is checked and matches/cascades resolved.