[solved] Guild chest drop info wrong

Platform, device version and operating system:
Android mobile, 6.2

Screenshot or image:

What you were expecting to happen, and what actually happened:
After reaching 40k seals, guild chests should give mythic, legendary, epic and ultra rare troops. But the drop info at level 6 only shows common and rare

How often does this happen? When did it begin happening?
Just saw it today

Steps to make it happen again
Reach 40k seals and open guild chests screen and tap on info button

Have you tried closing and re opening the game? A lot of these bugs with the shops and info are caused by the game being open from before reset and fix themselves when you close and open the game. On pc steam version our chests are showing as expected but I did do a close and open of the game after the weekly reset.


Ah a restart did fix it. Thank you.

1 Like

No problem at all maybe amend your title to represent that it was resolved. There are a lot of such issues that happen if the game is left open previous to a daily reset or weekly reset especially and I am unsure it could be resolved without major changes to the way the game forces information from updated content. My advice is ALWAYS close the game and open it after weekly reset and I also make sure to do so after each daily reset. If not you will almost always face issues with things not showing in the shops correctly and some information in game showing wrong information. I had these issues in the past and also had to be told that I needed to close and open the game because tiers in a faction assault were not present etc. It is annoying to deal with and I wish it was something they could fix but a lot of times when changes happen server side your client needs a restart to see it and without a client update which has to go through approvals on most platforms.