[Resolved] Purchased Fire Ruby Staff with gems but cannot locate in inventory


#1

Platform, device version and operating system:
Android, latest version, Google device

Screenshot or image:

What you were expecting to happen, and what actually happened:
pretty much what the title says. Bought the weapon to save time. Turns out I cant find it in inventory, even scrolling. First tried searching on Ruby then Fire.

How often does this happen? When did it begin happening?
well, it’s not fixing myself,and I’m out a ton of gems.

Steps to make it happen again
Yeah I’m not spending more gems. Please fix.


#3

Well if its resolved it should be in inventories- well it aint there.


#4

I tried one of the biggest hammers in my arsenal:
Quit and restart.

Worked.

Next would have been quit and purge memory. Then restart.
Then shut down phone completely and restart.
Then it’s reinstall program.
Final step would be to uninstall and not look back. But that’s pretty extreme.

Didn’t need to go that far.


#6

Hey thanks for reporting this, we didn’t notice any issues with the Fire Ruby Staff so it’s probably that your game client needed to refresh.

The fastest ways to do this are:

  • Force close the game and re-open it (definitely recommend if you’ve had the game open since before daily reset at 7am GMT)
  • open your game mailbox
  • play a pvp battle

I’m glad you were able to find it not too long after posting :slight_smile:

Just a reminder to everyone that if your post doesn’t help the OP or add more information about a bug please don’t post - it takes Dev time away from helping players with issues when we have to scroll through off topic posts.